SQL Monitor 11.1 is now available. Learn more.

SQL Monitor 11 Install Failed

I tried to install SQL Monitor 11 over the last release of 10.x and the install failed. It seems to be looking for an XML file in C:\Program Data\Red Gate\SQL Monitor\BaseLocation.config and it shows system error -2147024786. It tries to roll back but when it finishes SQL Monitor is not function.

It's installed on Windows Server 2016 on the E: drive. The database is on another server in SQL Server 2014.

Can you help me get back to a functioning installation.
Tagged:

Best Answers

Answers

  • marclenmarclen Posts: 5 New member
    I have the same Problem. To rename the Folder "%programdata%\Red Gate\SQL Monitor" worked for me. Thanks
  • TUellnerTUellner Posts: 44 Bronze 4
    Renaming the folder worked for me as well.
  • mykaskamykaska Posts: 14 Bronze 1
    edited October 20, 2020 9:06PM
    +1 
    the same issue

    the workround has  helped

    but now, if I click on any alert, I'm getting

    Sorry, this page cannot be found.
    This may be a mistake with SQL Monitor or you may have typed an invalid URL.

    If you think this is a problem with SQL Monitor please send us an email.

    Return to Global Overview
  • TUellnerTUellner Posts: 44 Bronze 4
    I am now seeing random "Monitoring Error" on servers on the dashboard. This has never happened with previous versions. Clicking on them takes me to the configuration for the server and I can retry the connection which works but it's tedious to deal with.
  • mykaskamykaska Posts: 14 Bronze 1
    >>I am now seeing random "Monitoring Error" on servers on the dashboard
    confirming the same
  • kevrileykevriley Preston, UKPosts: 129 Gold 1
    I had the same, but seem to be having some success with Alerts if I go to Configuration > Base Monitor and update my base monitor connection config. 

    In the file that was mentioned in the first error message "BaseLocation.config" I had

    <?xml version="1.0" encoding="utf-8"?>
    <baseMonitorLocations>
      <baseMonitorLocation networkName="localhost" portNum="7399"/>
    </baseMonitorLocations>

    but when I renamed the folder and let the installer recreate it I got

    <?xml version="1.0" encoding="utf-8"?>
    <baseMonitorLocations>
      <baseMonitorLocation networkName="" portNum="7399"/>
    </baseMonitorLocations>


    Having now re-configured my base monitor to be localhost, SQM seems much happier





    Not sure on the "Monitoring errors" though, they still seem to be happening


  • mykaskamykaska Posts: 14 Bronze 1
    Thank you, a lot, kevriley
    that fixed alert details issue
  • BodoBodo Posts: 6 New member
    the reconfiguration of the Base Monitor to "localhost" did not work for me. Still the same Problem: Randomly the Servers are going into the Red State !
  • There are three things going on in this thread now so I'll address each to clarify.  Also, all of them will be addressed by version 11.0.1 which was released yesterday (with a caveat on the third one with red monitoring status that I'll go into below):

    Issue on installation - renaming the %programdata% folder would have addressed this in V11.0.0 which it seems to have done for people above and it should no longer occur for moving to v11.0.1.

    The issue with viewing server overview, and alert details is due to the base monitor being unset from localhost to "" and so you can either edit the configuration file Kev mentioned or go to Configuration > Base monitor connections and set it there (to either localhost or to the name of the machine where you base monitor is located if on a different machine). Again, this should no longer occur from v11.0.1.

    The third issue is the monitoring status being red.  This is in two parts - the first part being the bug we've fixed the second part being expected behavior that we are considering options for.  To see which  you may be experiencing you can go to Configuration > Monitored servers, then mouse over the instance with the monitoring error and click on Show log at the right side to see what error is causing it.

    If it says Option<Object>.None has no value, that is the bug that is fixed in 11.0.1.

    If it says that he query has been deadlocked then this is expected behavior currently.

    Going into this last point a bit further, the tempdb object sampler was added in towards the end of v10.2.  There was an issue at first where it was deadlocking with another of our samplers (in 10.2.9) that was fixed but there is still the potential for it to deadlock with user processes that are using tempdb.  Our process will always be marked as the victim so it won't interfere in your processes.  It will however cause a monitoring error since the sampler failed - causing the status to turn red.  The query was rewritten for v11 with a view to reduce the chance of a deadlock occurring and in that rewrite the error you see above was introduced.

    So from 11.0.1 the query should deadlock less than it would have previously, but there is still the possibility of it doing so.  We are monitoring feedback on this and have a few options we're considering depending on that.
    Product Support Engineer | Redgate Software

    Have you visited our Help Center?
  • mykaskamykaska Posts: 14 Bronze 1
    edited October 22, 2020 1:23PM
    updated to 11.0.1
    the installation went smoothly. 

    getting a banner "Email alert notifications are failing. Configure notifications"
    I tried to send test e-mails and everything has worked with no issue.

    I'm not sure what is the banner trying to complain about..
  • marclenmarclen Posts: 5 New member
    edited October 22, 2020 1:44PM
    Same Error "
    Email alert notifications are failing. Configure Notification" here. Testmails are working fine. Hope for the next update ;-)

  • alexsdbaalexsdba Posts: 3 New member
    mykaska and marclen i'm also getting Email alert notifications are failing. Configure Notification.
    and test emails are working.
  • TUellnerTUellner Posts: 44 Bronze 4
    Clicking on the link in SQL Monitor to get the 11.0.1 update gives this error:

    Server Error

    404 - File or directory not found.

    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

  • Max_DrobotMax_Drobot Cambridge, UK Posts: 6 Bronze 1
    Hi all,

    We took the decision to remove the 11.0.1 installer following all the reports of "Email alert notifications are failing" message errors. We are working on a fix now and it should be available tomorrow.

    Thank you for all your feedback and my apologies for the errors you might have encountered when updating to SQL Monitor V11!
  • @TUellner ^^ is why you are seeing that message when using the link.
    Product Support Engineer | Redgate Software

    Have you visited our Help Center?
  • TUellnerTUellner Posts: 44 Bronze 4
    Still finding more broken stuff in 11.0

    When trying to look at a deadlock (extended event) I get this:

    Sorry, this page cannot be found.

    This may be a mistake with SQL Monitor or you may have typed an invalid URL.

    If you think this is a problem with SQL Monitor please send us an email.

    Return to Global Overview


    And if I try to go to overview page for a specific server, I just have empty graphs and tables that say "Loading..."

  • TUellnerTUellner Posts: 44 Bronze 4
    Thanks. Adding localhost to base monitor configuration fixed those two issues.
  • marclenmarclen Posts: 5 New member
    alexsdba said:
    mykaska and marclen i'm also getting Email alert notifications are failing. Configure Notification.
    and test emails are working.

    the Message keeps after reconfigure Notification and testing. I hope for the Hotfix
  • Hi All,

    The team have released SQL Monitor 11.0.2 which includes the fix for the issue with the email notifications failing.  The issue with the base location going missing should also be addressed and the TempDBObject sampler has also been disabled by default so you should no longer possibly see intermittent monitoring errors associated with it.

    You can download SQL Monitor 11.0.2 here: https://download.red-gate.com/checkforupdates/SQLMonitorWeb/SQLMonitorWeb_11.0.2.2486.exe
    Product Support Engineer | Redgate Software

    Have you visited our Help Center?
  • marclenmarclen Posts: 5 New member
    Hi Alex,
    Thank you for the new Release.
    Its working fine for me.
  • TUellnerTUellner Posts: 44 Bronze 4
    Hi Alex.

    11.0.2 is working well for me as well.
    Thank you all for the hard work.
Sign In or Register to comment.