What are the challenges you face when working across database platforms? Take the survey
Options

MSI package error

Hi guys!
Yet another MSI package error. I found a post regarding this error in SQL Toolbelt but nothing helped me so far... :cry:

As you can see I have a problem installing SQL Search. Every time I try to run the installer it tells me:



Let me explain what I did in chonological order (sorry for the long list but I want to be precise).
Becasue I was fighting with an issue that I had in Visual Studio 2015 (that one which prevents you from deploying SSIS projects becasue of missing library) I've installed tools unusually and in the meantime I've recived licence for prompt 9...

From the beggining:
0. Clean Windows 10 image
1. Install SSMS 18.2
2. Install Data Tools @VS2015
3. Install SQL Search
-> everything is working perfectly fine. Ok, I need to use Prompt, then I decided to install old SSSM

4. Install SSMS 17.9.1
5. Install Prompt 8 (that time I had only licence for 8)
-> SQL Search worked in SSMS 17 and 18, Prompt only in 17 (as there is no support for 18)
-> suddenly I realized that deploying SSIS packages is not working as it wokred before installation of SSMS 17, I decided to repair tools

6. Repair VS Data Tools 2015 (that one with shell isolated)
-> didn't help to my SSIS sissue
7. Repair SSMS 18 then 17
-> Did not help, Ok, I need to live with it for some time

8. Ive upgraded to Prompt 9 with a new licence (installation flder is still in ProgramFiles\Prompt8, just replacing some files)
-> I decided to fight again with the SSIS issue

8. Uninstall SSMS 17
9. Uninstall SSMS 18
10. Uninstall SSDT

-> Reboot

11. Install SSDT
12. Install SSMS 18
-> WOW my issue with SSIS was repaird, once again uninstall/install helped with the issue :upside down:
-> BUT now here I've found that Prompt is perfectly working but Search was not. SQL Search button was in SSMS but all fields were grayed out, did not respond to my clicks etc.

13. First try of repair SQL Search, the installation exe showed me the problem for the first time (exactly the same that I reported above)
14. I decided to uninstall SQL Search and reboot machine

and finally it didn't help... The issue is the same even if I uninstalled SQL Search manually (using Control Panel->Remove programs)

Do you have any suggestions?
I do not have SQL Search folder in program files, maybe something needs to be deleted in the windows registry? I tried to run the installation with a parameter "/supresschecks" but it did not work.. 

Please advise :cake:

Thanks!

edit: SQL Search 3.3 :)


Answers

Sign In or Register to comment.