SQL Search 3.3 not installing into SSMS 18.2

I can't get SQL Search to install into SSMS 18.2. Returns with the error : MSI returned failure code 1603: Fatal error during installation. Microsoft SQL Server Management Studio (SSMS) 2012, 2014, 2016 or 2017 required.

I have tired running the MSI directly from the temp folder as administrator - same error.

Any ideas?



  • Options
    Hi Brian, 

    Thanks for your post. 

    Have you recently uninstalled an older version of SSMS? Usually, an uninstallation of SSMS 17 can be the culprit! 

    Before removing the older version you will have needed to uninstall Redgate Products first. If you didnt, to fix the issue;

    •  Then reinstall Redgate Products in SSMS 18
    • And uninstall SSMS 17 last.
    If that doesn't apply to you, just say and we'll raise you a support ticket!
    Kind regards

    Robyn Edwards | Redgate Software
    Have you visited our Help Center?
  • Options
    BrianJonesBrianJones Posts: 2 New member
    Hi Robyn,

    That's worked, thank you ! Although I didn't need Revo Uninstaller - the standard Add..Remove worked perfectly.

Sign In or Register to comment.