Unable to use LocalDB with SmartAssembly


I created a localdb instace called SmartAssembly and started it.
I confirmed that the db is running, bot using the command line tool (sqllocaldb i SmartAssembly) and using LinqPad. However, when I enter (localdb)\SmartAssembly, or (LocalDB)\SmartAssembly or (LocalDb\SmartAssembly), SA keeps showing an error ("Could not connect to the SQL Server.")

What am I doing wrong? Although I did not find a direct documentation, the page below says: "MSSQL, MSSQL Express, SQL Server developer edition and LocalDB are supported".


Thanks in advance for your time.


  • Options
    RichardLRichardL Posts: 417 Gold 4
    Hi @csaba_fabian

    Thanks for your post. 

    If you drop the '\SmartAssembly' from the format you're written above then it should connect. 

    I hope this helps. 

    Kind regards

    Richard Lynch. 
    Customer Support
    Redgate Software
  • Options
    csaba_fabiancsaba_fabian Posts: 4 New member
    SOLVED. See next post.

    No luck. (Forgot to specify in original post that I am using SmartAssembly v6.12.3.697.)

    I realized that if I restart SA after changing the setting, I get more informative error messages, so here they are.

    When I try "(LocalDb)", "(localdb)" or "localdb", I get the following message at startup:

    "(localdb)\SmartAssembly", if I create the local db instance called SmartAssembly results in 

    If the localdb instance does not exist, it shows

  • Options
    csaba_fabiancsaba_fabian Posts: 4 New member
    So, looking at the last two error messages gave me the idea...

    I created the db manually, specifying the path to the mdf file explicitely:

    CREATE DATABASE SmartAssembly ON (
    FILENAME='<LOCALAPPDATA>\Microsoft\Microsoft SQL Server Local DB\Instances\SmartAssembly\SmartAssembly.mdf'

    And there it was, "(localdb)\SmartAssembly" started working. I'll keep you posted if I run into any other issues.
Sign In or Register to comment.