Error installing SQL Bundle 5 - MDAC 2.8 problem...

GrahamStonemanGrahamStoneman Posts: 4
edited April 11, 2006 8:18AM in SQL Compare Previous Versions
Hi there,

I'm trying to install SQL Bundle 5, but receive a message saying that I first need to install MDAC 2.8.

When I try to install MDAC 2.8 (downloaded from MS via the link on the Red Gate site), I receive a message saying that it's not needed on Windows XP since the features are already part of Windows.

So how do I install SQL Bundle?

Thanks very much,

Graham.

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Graham,

    Thanks for writing. I think you're right: SQL Bundle 5 is looking for MDAC 2.8 SP1 rather than 2.8 RTM. Until I get some clarification that SQL Bundle really needs MDAC 2.8 SP1 and we can adjust the installer, you may want to go to http://www.microsoft.com/downloads and get MDAC 2.8 SP1. The SQL Bundle Installer is putting down a minimum requirement for MDAC 2.80.1022.3.
  • Thanks for the prompt reply, but unfortunately I can't run any more MDAC installations on my machine. I already have MDAC 2.8 SP1, running on Windows XP SP2 - this was verified with the Component Checker tool available from the MS website. If it's helpful to you, my file versions are:

    MSADCOR.DLL 2.81.1117.0
    msado15.dll 2.81.1117.0
    MSADOMD.DLL 2.81.1117.0
    msadrh15.dll 2.81.1117.0
    MSDASC.DLL 2.81.1117.0
    MSDASQL.DLL 2.81.1117.0
    MSDASQLR.DLL 2.81.1117.0
    OLEDB32.DLL 2.81.1117.0
    SQLOLEDB.DLL 2000.085.1117.00
    SQLSRV32.DLL 2000.085.1117.00
    msdart.dll 2.81.1117.0
    msdaorar.dll 2.81.1117.0
    msorc32r.dll 2.575.1117.0

    My Windows version is:
    xpsp_sp2_rtm.040803-2158

    Please could you let me know if I'm missing any files? I can post any more information if you need it, I'm keen to get this resolved.

    Thanks,

    Graham.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Graham,

    Scratch that: the only thing that the installer checks is the registry key HKEY_LOCAL_MACHINE\Software\Microsoft\DataAccess\FullInstallVer. This version must be equal or greater than 2.80.1022.3.

    Windows XP SP2 will have an even newer version installed as part of the service pack. Windows XP SP1 and RTM users can use the link on our prerequisites page to update to the current version.

    Windows 2003 users are going to have a problem because the above installation will refuse to run on Windows 2003. The only way that I can see to get this working on W2K3 is to install Service Pack 1.

    We're currently validating this requirement and may drop the required version of MDAC down to Windows 2003 RTM's version to avoid future problems.

    This should happen around May when the SQL Bundle 5.1 maintenence release comes out.
  • Hi,

    Thanks - I changed the value of that registry key during installation and it worked fine (my original value was 2.60.6526.2 for some reason!).

    Cheers,

    Graham.
  • Hi,

    we will remove the requirement for MDAC 2.8 in SQL Bundle 5.1. Bundle 5.1 will be released in May 2006.

    Thanks,

    Tom Harris

    Red Gate Software
This discussion has been closed.