sco.exe Missing schemas from DataSource

llerracllerrac Posts: 8
edited August 16, 2013 5:03AM in Schema Compare for Oracle
I trialing out redgate for Oracle.
I am testing the TC connection and running the comparisons by hand.

from redgate TC guide, i wish to run command line compare with what I have in SVN
So guide reads>>
PreDeployReport (compares the contents of svn with a live database and generates a report of the differences). Command Line Executable:

C:\Program Files\Red Gate\Schema Compare for Oracle 3\SCO.exe
Parameters:

/source C:\DatabaseCI{WIDGET} /target User/[email protected]{WIDGET} /includeidentical /report:"PreDeploy.html" /reporttype:Interactive

<<
I then used these commands lines:
--direct file path to repo:
C:\Users\acarre>"C:\Program Files\Red Gate\Schema Compare for Oracle 3\"SCO.exe /source C:\Versioning\SVN4 /target lees/[email protected] /includeidentical /report:"Pre
Deploy.html" /reporttype:Interactive
Schema Compare for Oracle: in trial, expires 22-8-2013 6:13:11
Automation License: in trial, expires 22-8-2013 6:08:15
Error: Missing schemas from DataSource string C:\Versioning\SVN4, startOfSchemas = -1, endOfSchemas = -1


--the svn repo(where redgate version control placed it):
C:\Users\acarre>"C:\Program Files\Red Gate\Schema Compare for Oracle 3"\SCO.exe /source file:///C:/versioning/svn4/ /target lees/[email protected] /includeidentical /re
port:"PreDeploy.html" /reporttype:Interactive
Schema Compare for Oracle: in trial, expires 22-8-2013 6:13:11
Automation License: in trial, expires 22-8-2013 6:08:15
Error: Missing schemas from DataSource string file:///C:/versioning/svn4/, startOfSchemas = -1, endOfSchemas = -1

--a check out of the svn repo(as checked out by tortoise svn):
C:\Users\acarre>"C:\Program Files\Red Gate\Schema Compare for Oracle 3\"SCO.exe /source C:\Checkouts\svn4\ /target lees/[email protected] /includeidentical /report:"PreDeploy.html" /reporttype:Interactive
Schema Compare for Oracle: in trial, expires 22-8-2013 6:13:11
Automation License: in trial, expires 22-8-2013 6:08:15
Error: Missing schemas from DataSource string C:\Checkouts\svn4\, startOfSchemas = -1, endOfSchemas = -1

--
Any ideas? what have i missed

I have searched the forum, read the docs, but the CLI parameter /source seems not to be documented.


Thanks

Alex

fyi
the source control : SchemaInformation.xml has :
<?xml version="1.0" encoding="utf-16" standalone="yes"?>
<!--
SourceControlForOracle
Source Control for Oracle
Version:1.0.0.759-->
<SchemaInformation version="1" type="SchemaInformation">
<!--This is used instead of the folder name as some characters cannot be used when naming a folder-->
<Name>TOPLINE</Name>
</SchemaInformation>

Comments

  • Eddie DEddie D Posts: 1,462 Rose Gold 3
    Hi, thank your for your forum post.

    I agree that the help information for the command line needs some improvement and it is on my list of things to look at.

    I suspect that you may need to add the schema name in this format:
    &#123;schema_name&#125;
    

    So using your example your syntax may look like this, obviously replace schema_name with the name of your actual schema:
    C:\Users\acarre&gt;"C:\Program Files\Red Gate\Schema Compare for Oracle 3\"SCO.exe /source C:\Versioning\SVN4&#123;schema_name&#125; /target lees/[email protected]&#123;schema_name&#125; /includeidentical /report:"Pre 
    Deploy.html" /reporttype:Interactive 
    

    Another alternative if you have already configured your comparison through the GUI and saved the project, is to use the saved project file in the command line syntax. An example syntax is as follows:
    C:\Users\acarre&gt;"C:\Program Files\Red Gate\Schema Compare for Oracle 3"\SCO.exe /Project:"C:\Schema Compare for Oracle\Projects\WidgetDatabases.ocp" /re 
    port:"PreDeploy.html" /reporttype:Interactive 
    
    --where :"C:\Schema Compare for Oracle\Projects\WidgetDatabases.ocp" is the path to the saved project file
    

    I hope the above helps.

    Many Thanks
    Eddie
    Eddie Davis
    Product Support Engineer
    Redgate Software Ltd
    Email: [email protected]
  • Hi
    Thanks for the reply
  • Out of interest.
    where the above example gives {schema} for the TNS log in, use a standard tns logline commmand line and that seems to connect.
    eg user/[email protected]:port/schema

    As for the SVN schema, using "{schema}" fails as does "/schema" , "\schema" , "schema"
    eg
    C:\Versioning\SVN4\testschema
    error:
    Schema Compare for Oracle: in trial, expires 22-8-2013 6:13:11
    Automation License: in trial, expires 22-8-2013 6:08:15
    Error: Missing schemas from DataSource string C:\Versioning\SVN4:testschema,
    startOfSchemas = -1, endOfSchemas = -1


    I may be being daft.
  • Also relating to the example above

    The ocp driven command should look like this:

    "C:\Program Files\Red Gate\Schema Compare for Oracle 3"\SCO.exe /project "C:\Temp\redgate\TC1\db1 to db2.ocp" /report:"PreDeploy.html" /reporttype:Interactive


    Though in my case I get:

    Automation License: in trial, expires 22-8-2013 6:08:15
    Checking that DataSources can be parsed
    Reading dependency information
    Error: Can not obtain Oracle client information from registry. Make sure that
    Oracle Client Software is installed, or use Direct mode of connecting to server.

    - while I know my registry setting is correct.. i have had to check it enough times.
    I do have a reg setting for XE and one oracle 11g though. I suspect the above is due to the XE entry.

    *it works using the UI*

    Any thoughts?

    Thanks

    Alex
Sign In or Register to comment.