Bad performance and regular timeouts using shared model

knoepplerknoeppler Posts: 4

we are using the shared database development model with SVN. Ever since the last SQL Source Control Update (to Version, we receive regularly error messages about failing to poll for 3 seconds. We have sent error messages about this to Redgate several times via the error reporting feature, though without a reaction so far. Also, when trying to commit, the commit dialog sometimes shows a message saying "Waiting for other operations to complete" indefinitely, keeping users from committing their changes.

Accidentally, I discovered the Asteriods easter egg while waiting for the commit dialog, but actually I'd prefer if I could commit my changes...

If nothing else helps, could you consider rolling back to handling the shared model like you did before version 3, or at least give the user a choice in this respect? We never had a problem finding out who changed what when committing changes, but now we regularly have problems committing changes, to an extent that renders SQL Source Control almost unusable.


  • We're aware of some issues people have been seeing with the shared model in SQL Source Control 3.1 - if you want, you can always downgrade to SQL Source Control 3.0 and wait for the patched update.

    The installer for SQL Source Control 3.0 is here: ... 3.4214.exe

    If you uninstall SQL Source Control 3.0 and install that, you ought to be able to continue to work with your database with the old-style limited change-tracking. Let me know if that helps at all! I'll update this thread as soon as there's a newer version of SQL Source Control out.
    Andy Campbell Smith

    Red Gate Technical Support Engineer
  • Hi,

    Our team is having exactly the same issues as knoeppler. Team of 8 all on V3.1.0.4829 of SSC doing Shared development with TFS. The software is unusable as we are not able to refresh the commit changes tab without getting either a timeout or polled 3 times error. I have also sent both the error reports and a support ticket to RedGate but have had no response so far.

    I just tried downgrading as suggested above and when I tried to re-link the databases to TFS with V3.0 I got the error "Operation is not valid due to the current state of the object." Are there any other ways that we could fix this in the interim? Unluckily for us, we only started using SSC this week!

    Thanks in advance,

  • Hmm. You could try reducing the polling time of SQL Source Control. You can do this by editing the RedGate_SQLSourceControl_Engine_EngineOptions.xml file in C:\Users\<username>\Appdata\Local\Red Gate\SQL Source Control 3.

    Set the trace interval time as follows:


    (you may need to add that line if it's not already there).

    Once done, ensure you restart SSMS; also, you will need to perform this change on each PC / for each user.
    Andy Campbell Smith

    Red Gate Technical Support Engineer
  • Hi Andy,

    Thanks for your response, it seems to have fixed the issue for us.

    Do you have any idea when a patch is likely to be released?
    When it is released, should we remove the configuration, or leave it as it is?


  • We're working on a patched version of SQL Source Control currently, but I don't know when that'll be ready - it shouldn't be too long, but I can't promise any dates. I'll post here as soon as it's out.

    All you changed in the config file is the max timeout value - you can safely leave that as it is if the software's patched.
    Andy Campbell Smith

    Red Gate Technical Support Engineer
  • Any word on this Patch?

    I cannot get my Source Control 3 install to pull up stuff in the "Commit" tab since last update.. currently on

    I get either

    "Failed to poll database after 3 attempts"


    "Timeout Expired"

    when i just try to get the list of objects needing to be checked in

    We are using Vault as our source control depository and it works great with Visual Studio for code, the Vault client works great too, so I know that it is in full working order
  • So:
    - Uninstalled the version of 3.1
    - Downloaded the version 3.0 linked to above...
    - Install went smooth, all my savings were saved
    - Can now pull up that commit tab and check items in
  • My team of 9 has been experiencing the same issue for a while now. I finally got around to googling today and I'm glad I found this thread. I'm commenting mostly to subscribe so I will be sure to know when the update is out. I hope the update is soon-- the usability of SSC has been greatly impacted by this repeated error.
  • Just to let you know - we've now released a new version of SQL Source Control which should hopefully fix some of the problems you were seeing. You can download using the Check for Updates functionality within the tool - let me know if that sorts anything out for you!
    Andy Campbell Smith

    Red Gate Technical Support Engineer
  • Has anyone out there in this thread tried the new update to address this problem?

    I rolled back to an old version and don't want to be the guinea pig for this new version :-)
  • My team has updated. We had some weird locking errors when only half the team was on the new version and the other half was on the old version. A restart of SQL seemed to fix it, so it may have just been a gremlin.

    Since then, I haven't noticed the timeout errors at all. I E-mailed my team to see if anyone else has seen the timeouts since upgrading. From what I can tell, it's stable.

    Thanks RedGate!
  • Wow, I just noticed that a brand new minor release (3.1.2) just came out today. All the site says is "several major bug fixes". Does anyone know specifically what it fixes?

  • The two major bugs addressed in that minor release were SOC-4584 (Crash when removing polling manager) and SOC-2779 (Crash when object is defined in multiple files on disk). We also fixed an issue that was causing trouble in SQL Compare comparing to versions in source control history.

    A little update - the improvements to polling problems are just that, improvements (i.e. not a true fix). The root cause of the problem is that all users in a shared model environment are polling the same table to get blue blobs - that's still the case, but we've about halved the execution time of the polling query, so it should be significantly less of an issue.

    We are working on a new model of polling for shared model environments that won't rely on every user polling the same table, but that's still in the pipeline. Hopefully this ought to help a lot in the meantime!
    Andy Campbell Smith

    Red Gate Technical Support Engineer
Sign In or Register to comment.