Viewstate authentication and HttpRequest.Location

myurkusmyurkus Posts: 3
edited May 25, 2005 5:54AM in ANTS Load
Hello, I am working with the trial version of ANTs Load (FWIW our company is almost definitely going to buy a license.)

I am trying to simulate a user login; however, it never makes it past the login screen to the actual POST.

I receive the following error:

"...Authentication of viewstate failed..."

I saw that some other people have run into redirection problems, so I tried adding the following line before my post:

WebClient.Get(WebClient.HttpResponse.Location)

However, I confirmed that even after my previous "get" the HttpResponse.Location object is Null.

Can anyone please help me with this? Thanks you very much in advance!

Mike

Addendum: I just tried the simplest script possible (go to goole.com and search for ANTS"); HttpResponse still does not have a location object populated.

Comments

  • Update on my problem:

    The website I am changing never does a 302 redirect...that's why location was blank.

    However, I am seeing the same Viewstate problem that others are seeing (it is clearly there in HttpResponse.Contents but it is blank in WebClient.ViewState.)

    Any ideas on this one?
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    Can you post the ANTS Load script? I'm willing to bet that the reason that the viewstate is invalid is because of a missing initial GET to the login page.
  • We are getting the same exact errors. The http errors after creating an ants script say that the viewstate failed authentication. Our registration pages don't require login at all. If you could take a look at the text file I'm about to PM you, I'd appreciate it. We'd like to buy a license, but not if the app needs manual tweaks done that take a long time.

    Thanks a bundle.
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello,

    I've tried to send a patch that corrects a problem handing cookies written by the forms authentication in ASP .NET, but your mail server rejects all zip attachments. Can you please send me a private message with an email address that will accept the attachment?
This discussion has been closed.