Visual Studio 2010

youngcm2youngcm2 Posts: 14
edited November 4, 2010 7:54AM in SQL Prompt Previous Versions
Do you know when a beta will be available for VS 2010? Will there be better support for VS Database Developer?

Comments

  • Many thanks for your post.

    Till now we haven't heard about any issues regarding SQL Prompt not working with Visual Studio 2010.

    Can you kindly let me know if you are experiencing any issues with it?
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • I just installed VS2010 ultimate beta 2, and the SQL prompt menu is not showing. Do I need to reinstall SQL prompt or is there something I need to do with VS2010?

    Thanks
    Database Analyst
    Alberta Justice and Solicitor General
  • Yes please, Reinstalling SQL Prompt shoud ideally fix the issue.

    Kindly let me know the outcome.
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • Got a new box and tryed this again (Winodws 7), I installed SQL Server 2008, Visual Studio 2010 (Beta 2) and then installed SQL Prompt, I get SQL prompt in SQL server management studio but I still do not see the SQL Prompt 4 menu in Visual Studiio 2010.

    2 things to note are, I am running a 64 bit edition of Windows 7 Enterprise and I am running the client for SQL 2008 R2 CTP.

    If any one has any ideas or command line suggestions to get SQL prompt into Visual studio I would be happy.

    Note: It seems that SQL 2008 R2 CTP doesn't like SQL Refactor. Just FYI.
    Database Analyst
    Alberta Justice and Solicitor General
  • Hello aseniuk,

    I am sorry to hear you are having problems with SQL Prompt.

    Can you try adding the path (by default: C:\Program Files (x86)\Red Gate\SQL Prompt 4) manually in Visual Studio. You can do that by navigating to Tools –> options –> add-in/macros security and add the SQL Prompt add-in. Ensure that Tools>Add-in Manager "Include SQL Prompt at startup" is checked then restart the Visual Studio.

    If this doesn't work, then try re-registering the DLL:

    1. Open a command prompt, change the directory to the SQL Prompt installation folder. Run

    %SYSTEMROOT%\Microsoft.net\Framework\v2.0.50727\regasm "%ProgramFiles%\Red Gate\SQL Prompt 4\RedGate.SQLPrompt.VSUI.dll"

    2. Run devenv /ResetSettings in Run window.

    Kindly let me know if this fixes the issue.

    Note: We have a fix for the SQL Refactor not working with SQL 2008 R2 CTP kindly download the latest version from here.
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • Unfortunately that didn't work. I ran the commands and reset visual studio.

    Just to note, %SYSTEMROOT%\Microsoft.net\Framework\v2.0.50727\regasm "%ProgramFiles%\Red Gate\SQL Prompt 4\RedGate.SQLPrompt.VSUI.dll" should be %SYSTEMROOT%\Microsoft.net\Framework\v2.0.50727\regasm "%ProgramFiles(x86)%\Red Gate\SQL Prompt 4\RedGate.SQLPrompt.VSUI.dll"

    Is there something else I need to do during the install?
    Database Analyst
    Alberta Justice and Solicitor General
  • You will need to make a hot fix for the application to include this text

    <HostApplication>
    <Name>Microsoft Visual Studio Macros</Name>
    <Version>10.0</Version>
    </HostApplication>
    <HostApplication>
    <Name>Microsoft Visual Studio</Name>
    <Version>10.0</Version>
    </HostApplication>

    in the file VSUI.AddIn

    Thanks.
    Database Analyst
    Alberta Justice and Solicitor General
  • I tried everything suggested,but it just doesn't work.
    There is not a "sql prompt 4" menu in the visual studio 2010.
    :(
  • Is there a final resolution to this issue. Just like regspc, I have tried all of the suggestions, and I have met with no success.

    Any additional insight will be greatly appreciated.
  • I still can't get SQL Prompt working in Visual Studio 2010 following the guides in this thread. I have also tried uninstalling and reinstalling SQL Prompt.

    How do we get this working in Visual Studio 2010?
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Edit the .addin file as described in a previous post to this topic to update the host application to 10.0 and save, then ensure that in VS2010 tools->options, the path to the .addin (c:\program files (x86)\red gate\sql prompt 4) is shown in add-in/macro security.

    Works on my computer!TM
Sign In or Register to comment.