Web Application ... not loaded the .NET Framework

Seen this many times in the forum before .... but to no avail!

We're running ANTS Profiler v2.5 (downloaded today), Windows 2003 Server (so .Net 1.1 only) - with the application's app pool running under LocalSystem and machine.config process model set to be System...

Running "Profile Memory" , when we attempt to take a snapshot, we get the old:

The web application ... has not loaded the .NET Framework. Please check that ... is an ASP.net web application. Please note that accessing cached web pages will not load the .NET Framework.




Tried this software a while back, same errors .. never got it to work.

Any suggestions welcome, would happily buy a copy if it works!

Cheers guys

S

Comments

  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Stefan,

    Does this happen even if you profile all methods rather than profiling only methods that have source code? If you're using the latter profiling filter method, then it may be an issue related to finding the source code.

    This can be fixed a majority of the time by making sure that the software you're profiling is a debug build and that the .pdb file exists alongside the dll or exe.
  • Running "Profile Memory" ..... i.e. these options aren't shown

    Cheers

    S
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hi Sefan,

    Sorry -- I didn't notice that you had mentioned memory profiling. I'll come up with another suggestion in a minute.
  • I have sent you a mail with some instructions on how to enable logging in ANTS Profiler. This would enable us to determine what might be going wrong in your setup.

    Thanks,

    Tom Harris
  • I believe that ANTS needs the aspnet worker process (aspnet_wp.exe or w3wp.exe under Windows 2003) to be started when you load your web app (aspx). Under the .Net framework CONFIG directory (c:\windows\microsoft.net\framework\v1.1.4322\CONFIG) there is a machine.config file. Open up and look for 'processModel'. There will be an xml attribute for enable=false or enable=true. ENsure that it is set to true, and your web app will start up under the asp.Net worker process instead of under IIS (inetinfo.exe or dllhost). Purify and Quantify require you to disable the processModel for IIS and ASP.Net profiuleing.
    Ciao!
    Jim Shaw

    Shaw Software Consulting Inc
  • Brian DonahueBrian Donahue Posts: 6,590 New member
    Hello Jim,

    I think that's part right. ANTS Profiler needs the processModel enabled, but only so that it can get the ASPNET user credentials. It's always going to profile the inetinfo.exe process (except in IIS 6 -- it does something different), in the case of COM+ serviced components, it launches and profiles dllhost.exe.
This discussion has been closed.