SQL Backup Pro - Server Problem

AttilaY2KAttilaY2K Posts: 2
I have installed the version 6.2.0.134 just purchased on two different server but for both I receive a strange error message:

Title: "A problem was encountered whilst communicating with the server."
Body: "Query error: The data type is not valid for the boolean operation. [Data type (if known)=datetime, Data type (if known)=nvarchar]"

has someone already had this problem? how has you resolved?
My regional settings are set in Italian, and SQL collation is Latin1_General_CI_AS; MSSQL release is 9.00.4035.00 (MSSQL 2005) and operating system are:
- Windows Server 2003 Enterprise R2 SP2 (first server)
- Windows Server 2008 Standard SP2 (second server)

Please HELP ME!!!!

Comments

  • I tried this on Win 2008 + Italian language pack and I'm getting the same error as you. I'll do my best to get this fixed ASAP.

    In the mean time, please use the extended stored procedure or command line tool to manually to run your backups. The .chm help file in the install directory provides the syntax.

    Regards,
    Robin Anderson
    Development
    Red-Gate Software
  • Glad to hear the hotfix we sent you has resolved this issue.
    Helen Joyce
    SQL Backup Project Manager
    Red Gate Software
  • ...with the server.

    I have five registered servers and receive an red box with X symbol on a three of them indicating "A problem was encountered whilst communicating with the server". If I click on the server it eventually goes away and I can use the software as desired. The message below is the detail of the error:


    System.ArgumentOutOfRangeException: Length cannot be less than zero.
    Parameter name: length
    at System.String.InternalSubStringWithChecks(Int32 startIndex, Int32 length, Boolean fAlwaysCopy)
    at b.visit(AST node)
    at b.visit(AST node)
    at b.visit(AST node)
    at b.visit(AST node)
    at b.visit(AST node)
    at b.visit(AST node)
    at b.visit(AST node)
    at b.visit(AST node)
    at b.visit(AST node)
    at b.visit(AST node)
    at b.visit(AST node)
    at b.visit(AST node)
    at b.visit(AST node)
    at b.visit(AST node)
    at b.visit(AST node)
    at w.a(String )
    at j.a(Server , Job , SqlDataReader )
    at p.a(Server , Job )
    at RedGate.SQLBackup.Engine.Job.a(SqlDataReader )
    at RedGate.SQLBackup.Engine.Job..ctor(Server server, SqlDataReader dataReader)
    at i.a(Server , SqlDataReader )
    at p.a(Server )
    at RedGate.SQLBackup.Engine.Server.RefreshJobInformation()

    SQL 2005 Enterprise, SP3
    Win 2003 Server Standard Edition, SP2

    I have three more servers to add and would like to know how I can avoid this issue moving forward. The installs have not indicated any errors during the process and complete successfully.

    Thanks in advance.
  • RBARBA Posts: 152 Silver 3
    Hi Murphy,

    This issue has been fixed and will be available with other changes when the next update is released. However, there is a patch I can send you to fix the issue in advance of this (I've emailed you details).

    Customers who experience this issue can contact me directly for a patch ([email protected]) rather than wait for the 6.5 release.

    Regards,
    Robin Anderson
    Development
    Red-Gate Software
Sign In or Register to comment.