MSQL_XP lastwaittype in sysprocesses when doing log restore.

swirl80swirl80 Posts: 26
edited September 14, 2009 3:55PM in SQL Backup Previous Versions
I've been trying to temporarily move our reports server to another box and when i go live with it the log restores get slower and slower. On investigation i've noticed that when the restore job starts it'll restore the first database file then wait for around 5-10mins before moving onto the next file. When this is happening i've noticed a lastwaittype of MSQL_XP and the waittime going up and up. I understand what this waittype is but can't work out why its taking so long to clear as it clears almost instant on our current box (which is exactly the same model / spec as the one i'm trying to move it to).

So, a job to restore 17 log files which should take no more than 10mins can take up to an hour, if not longer.

I've just installed v5.4 (from 5.3) to see if this improves the issue but i've restarted the sql service which may have cleared any buffer / caching issues that i was having so will report back later.

Is there any known issues as to why this could be??

Comments

  • Eddie DEddie D Posts: 1,733 Rose Gold 5
    Thank you for your post into the forum and sorry that you are experiencing this problem.

    How many concurrent SQL Backup tasks to you have running?

    Can you please check the SQL Server Error Logs, do you have any entries that are reporting locks or deadlocks to the msdb database by the SQBCoreService.exe?

    Many Thanks
    Eddie
    Eddie Davis
    Senior Product Support Engineer
    Redgate Software Ltd
    Email: [email protected]
Sign In or Register to comment.