IIS app profiling is odd.

sseelysseely Posts: 7
Environment: Win7 x64, IIS 7.5
Memory Profiler Version:

Tried running Memory Profiler as limited user and as admin, results are identical.

Steps to repro:
1. Install BuggyBits example from here as a web app in IIS: http://blogs.msdn.com/tess/pages/net-de ... tions.aspx (buggybits site is an attachment at the end of the post)

2. In App Settings, select application type to profile: ASP.NET web application (hosted in IIS)
Profile On: Original Port (IIS will reset)

3. Click on 'Start Profiling'

Memory Profiler is stuck on 'Starting application...' and won't go to the next stage until I navigate to a few pages within the app. Why?


  • I'm investigatng this (thanks for the steps). In the meantime can you try the same procedure and ensure no other web sites are using port 80?
  • Well, I've got my BuggyBits up and running and profiling nicely. I'm using 64-bit Win 2008, IIS7; same ANTS version as yourself. I'm the local administrator. I expect it is a permissions issue. As another suggestion, can you also try using the "unused port" option?
  • Chris,
    I have the following settings:
    App type to profile: ASP.NET Web Application (hosted in IIS)
    ASP.NET web application URL: http://localhost/BuggyBits
    Profile on: Original port

    The profiling still doesn't kick in (that is, I can't select Take Memory Snapshot) until I navigate to a new page, like http://localhost/BuggyBits/News.aspx.
  • That's not unexpected, I think: the profiling should only start when the .NET runtime is loaded by IIS, which doesn't happen until you navigate to the first .aspx page in this case.

    There's actually no memory being used by .NET at all until this happens, which is why the take snapshot button remains disabled.
    Andrew Hunter
    Software Developer
    Red Gate Software Ltd.
  • Thanks. that makes sense, though it was a bit surprising at first. Might be worth some documentation (or is this fact in there already?).
Sign In or Register to comment.