What are the challenges you face when working across database platforms? Take the survey

Interesting quirk in command line

lfreijolfreijo Posts: 16 Bronze 2
edited August 6, 2009 6:42AM in SQL Compare Previous Versions
I found an interesting quirk, not sure what it actually means.

I used sql compare command line to do a synchronization between a snapshot and an empty database.

sqlcompare /snapshot1:"\\fileserver\driveshare$\folder\server.database.snp" /server2:server /database2:database /synchronize /force

The command kept failing saying there was incorrect syntax after a "go". I ran the compare through the gui and it worked fine. I created a script using the command line and the script ran fine. However it failed everytime I ran it in the command window.

Finally I tried the command line using the /ignoreParserErrors option. Once I did this it worked fine. I think it might have seen the word go in a comment and assumed it was a command.


  • Options
    Thanks for your post.

    I haven't seen this happen before.

    Would you be able to send the snapshot file you used to support@red-gate.com

    If you could add the reference F0025139 in the subject line, it will update the ticket we have opened for you.

    I look forward to hearing from you.
Sign In or Register to comment.