Warning 402: Failed to open local data store:

hbucknerhbuckner Posts: 67 Bronze 3
edited May 13, 2014 4:21PM in SQL Backup Previous Versions
I have just installed SQL Backup 6 server components on a 64 bit cluster. Everything installed fine, service is started, and a cluster resource created.

When open the SQLBackup GUI on another machine, and connect to the server I'm getting the following error...

Warning 402: Failed to open local data store: There is a file sharing violation. A different process might be using the file. [\\sqlbkup_test\sqlbkup_test\vSQLPatriot\Redgate\data.sdf]

Any idea where to start trouble shooting?

Comments

  • Can you please turn on logging for the service by doing the following :

    Open regedit and navigate to the following registry key :

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SQLBackupAgent(_InstanceName)

    Modify the ImagePath value by appending -sqbdebug to the end of the string.

    Now please try restarting the SQL Backup Agent.

    A log file should be created in the Server Components Installation directory (%:\Program Files\Red Gate\SQL Backup\<instance name> by default).

    Could you please send me any log files contained there ([email protected] , subject: F0024635)?

    If no log is created, please ensure the SQL Backup Agent Service has permissions to write to the folder where it is located.
  • I am having the exact same problem.

    What was the resolution?

    Thanks!
  • peteypetey Posts: 2,358 New member
    Could you please use Process Explorer or Handle (from Sysinternals/Microsoft) to determine which process is locking the data.sdf file on the server?

    Thanks.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • I fixed this issue on my server.
    For some reason, changing the reg key HKLM\SYSTEM\CurrentControlSet\Services\SQLBackupAgent by adding the -sqbdebug to the end fixed the problem.
    I took the -sqbdebug to the end off the string and it still worked.
    Not sure why this fixed it but give it a try.
Sign In or Register to comment.