ZLib decompression error when encrypted

bdillbdill Posts: 41
edited September 7, 2009 8:56AM in SQB2MTF GUI utility
SQLBackup version: 6.0.0.412
SQBConverterGUI version: 6.1.0.16
(includes RgSqbConvHelper.dll ver: 6.1.0.16
and RedGate.Shared.Controls.dll ver: 7.4.0.7)

When I first tried to convert an encrypted *.sqb to *.bak, I got the following error:
Data decompression error: ZLib decompression error: data error

I verified the files using an MD5 utility, and they matched, so it isn't a file copying issue.

My password had special characters and was long (30 chars), so I made another encrypted backup with a small password using only letters/numbers. I got the same error.

I did another full backup, but this time I did NOT encrypt the backup. That *.sqb file converted successfully.

1) Can anybody at Red-Gate replicate this behavior?
2) Is my version of the SQB2MTF utility incompatible with the my version of SQL Backup version?

Comments

  • Hi bdill,

    This is a known issue and has now been resolved in the latest build.

    This fix will be present in the next minor release, but you can email me (robin.anderson {at} red-gate.com) for a copy of the latest exe and related drivers before then.

    Regards,
    Robin Anderson
    Development
    Red-Gate Software
Sign In or Register to comment.