What are the challenges you face when working across database platforms? Take the survey
Options

Crypto error when starting Perf Profiler 4.3.0.198

Hi,

I've installed Performance Profiler 4.3.0.198 on a Vista x64 machine, when I start the profiler I get the following error message:

Failed to decrypt data (Win32 error code:0x8009000b): Key not valid for use in specified state.
System.Security.Cryptography.CryptographicException

<stack trace>
at RedGate.Profiler.Project.IIS6_7Settings.GetPasswordSlightlyMoreSecure()
<more stack trace>

If I click OK, the app continues to start but I then get the same message if I attempt to create a new profiling session. I can supply a screenshot of the full exception dialog if required (I'm not able to attach it to this post).

I've reinstalled the app - no change.

My config is Vista x64, IIS7 & VS2008.

Any ideas what may be the problem?

Thanks

Comments

  • Options
    Hi KazR,
    That's not one I've seem before. I wonder, did this happen the very first time you opened the profiler, or did it develop after a couple of uses?

    If it developed later, I think it may be a problem with an old project settings file. You can try clearing the profiler's startup project settings, by deleting any files that have a path something like:

    C:\Users\alex.davies\Local Settings\Application Data\IsolatedStorage\xkeuecxr.225\rkl31svo.yby\StrongName.ijjuoc43iwe3ingfwrfydjwu2fxh2ckj\AssemFiles\APP4_LastProjectSettings.xml

    Obviously replacing my username with yours, and exploring to find the right random sequences of characters (everything there is pretty temporary, so don't be too worried about deleting things).

    Also delete any saved project files you may have to ensure they aren't loaded instead.

    Let me know how it goes,
    A
    Alex
    Developer,
    Red Gate .NET Tools
  • Options
    Hi,

    Thanks for the fast response, I eventually found the XML file (I couldn't navigate through my Local Settings 'link' for some reason), I removed it and the app now starts up correctly!

    Thank you very much!
    Kaz
Sign In or Register to comment.