Refresh Cache keyboard shortcut missing

peschkajpeschkaj Posts: 5
edited June 18, 2009 3:26AM in SQL Prompt Previous Versions
When I attempt to use CTRL+SHIFT+D to refresh the cache nothing happens. However, this option is available from the SQL Prompt menu in SSMS. The menu item does not have a keyboard shortcut next to it.

When I open up my settings file and locate the command for RedGate.SQLPrompt.SSMSUI.RefreshCache, I find that it is located in a DisableShortcut element. If I change this to a Shortcut element, it is changed back when SSMS is restarted.

Any help on this would be appreciated.

Thanks,

Jeremiah

Comments

  • Anu DAnu D Posts: 876 Silver 3
    Thanks for your post.

    Kindly let us know the versions of SQL prompt and Management Studio you are using?

    Can you also let us know if there's any pattern to replicate this issue?

    The above details will help us to investigate further.
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • I'm using:

    SQL Prompt 3.9.0.43
    SQL Server Management Studio 10.0.2531.0

    Basically, I installed SQL Prompt through the SQL Toolbelt and when I used it the first time, I could refresh the schema. At a later launch the keyboard shortcut was disabled in SSMS but the schema refresh could still be performed via the SQL Prompt menu.

    This is on Windows 7 Build 7100.

    I also have VSTS 2008 Database Developer Edition GDR installed. The keyboard shortcut is still available in VSTS.
  • Can you kindly explain us which settings file are you referring to?
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • Can you kindly explain us which settings file are you referring to?

    Sure thing, it's the file location at:

    C:\Users\USERNAME\Documents\SQL Server Management Studio\Settings\CurrentSettings-2009-05-24.vssettings
  • Anu DAnu D Posts: 876 Silver 3
    Thanks for the help.

    By any chance do you have Window-Eyes 7.0 installed on your machine?
    As Window-Eyes 7.0's Field Data uses CTRL-SHIFT-D as shortcut.

    Could you kindly try following things:
    1. Disable Window-Eyes 7.0 from your machine
    2. Change RedGate.SQLPrompt.SSMSUI.RefreshCache to Shortcut element from DisableShortcut
    3. Check if it works for you.

    If it doesnt work we need to find out which other process is using this shortcut.
    You could download Process Explorer from here.

    And if you could send us the screenshot of the same on [email protected] and we will take forward from there.
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • I do not have Window Eyes installed, but after following your steps the problem was resolved. Thank you.
  • Anu DAnu D Posts: 876 Silver 3
    Brilliant news that your issue is resolved!
    Thanks for the update.
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
Sign In or Register to comment.