What are the challenges you face when working across database platforms? Take the survey
Options

Prompt stopped working in latest update for certain scripts

JWylieJWylie Posts: 2 New member
I have many scripts that build stored procedures for my database that I have been using prompt on for quite some time now with no issues. After the recent update, I am getting this error on all of them. 

My scripts check for a schema and creates it if needed. then checks for the procedure and drops if needed (don't know if client has SQL server version that supports CREATE or ALTER which is why I do this), I then go into creating the procedure. In the procedure I have XML parameters I parse and put into temp tables then I get into the actual query to gather the data. If I pull out the query itself and format just that part, everything works fine. I can execute the script to create the procedure and it works fine. The procedure even executes as expected so there are no errors in the code. Prompt will just not format these scripts anymore. 

I am running version 10.13.16.3650
I just turned on verbose logging, tried to format a few times, and have attached the log here as well. 
Tagged:

Answers

  • Options
    Hi @JWylie

    Thanks for reaching out on the Redgate forums and sorry to hear about this issue in your SQL Prompt.

    Can I request you conduct a fresh installation of SQL Prompt in version v10.14.0. Download link here:
    https://download.red-gate.com/checkforupdates/SQLPrompt/SQLPrompt_10.14.0.4064.exe
    Then check if the error is still occurring.

    If it is, can you please provide a new copy of your Verbose logging & an example of a script that is creating this error message, so we can replicate it locally as a possible bug.

    I have created a secure link for you to provide this information. The link will be valid for 14 days
    https://files.red-gate.com/requests/84Jkux4v1PUpLAA6BZKpQg
    Jon Kirkwood | Technical Support Engineer | Redgate Software
  • Options
    JWylieJWylie Posts: 2 New member
    Thanks. I uninstalled and reinstalled like requested but still get the same error. I am sending the logging as well as a few of the procedure scripts that are causing the error. One of the scripts (in the dbo schema) I am sending has been in our system for years so I know formatting has worked on it in the past because that is how it got formatted to go into our update code. The second one is one I have been working on for a few weeks now for a client (OSC schema) and I thought at first I might have had an error in the script causing the formatting to fail but that's when I remembered it was working before I updated. Additionally I can execute the script to create the procedure and it works fine so I know there isn't an error in the script code. 
Sign In or Register to comment.