What are the challenges you face when working across database platforms? Take the survey
Options

SmartAssembly UI incorrectly complains that .NET Framework is not installed

We have a .NET solution with which I've used SmartAssembly successfully for several years (currently running v6.8.0.121). Recently we have upgraded the target framework for all projects in the solution to .NET 4.7.2. Now, when attempting to add or open a SmartAssembly project for one of the output assemblies, the SmartAssembly UI gives the message:

'This assembly targets .NET Framework v4.7, which is not available on this computer. Install the associated .NET Framework to process this assembly.'

(A link is provided to the Microsoft downloads home page.)

I installed the .NET 4.7.2 runtime and developer pack but received the same message from SmartAssembly, even after rebooting and confirming the installations were successful.

Despite our solution targeting v4.7.2, the SmartAssembly message actually states that v4.7 is required, but even if this is the case, the v4.7 runtime cannot be installed if v4.7.2 is already installed (and I cannot find a way to uninstall the v4.7.2 runtime, even using e.g. wmic - not that this is an acceptable solution in any case).

Is this a bug in SmartAssembly? Is there a workaround or other way to bypass this error message? The 'Build' button is greyed out so I cannot get past this screen. Using the SmartAssembly command-line utility might be possible but is not a viable long-term option for us.
Tagged:

Answers

Sign In or Register to comment.