What are the challenges you face when working across database platforms? Take the survey
Options

Can't see line graph for Performance Counters

I'm using the trial version of ANTS Profiler 4 on Windows XP SP3 to profile an ASP .NET 2.0 webapp running locally in either IIS or VS 2005's WebDev server app, and while I do see the execution times/counts of methods, I don't see the line graph that's supposed to represent CPU Usage (default) or the other performance counters chosen in the tool's UI.

Does this hook into Windows' performance counters? Is there any way to troubleshoot this and make sure it's properly using that service? (For reference, I don't think I have any sort of firewall/security app that would prevent this)

Any help you could provide would be greatly appreciated. Thanks!

Comments

  • Options
    It could possibly be a permissions problem. Is your logon denied the "Profile System Performance" or "Profile Single Process" right in the local security policy?

    Alternatively - check out this article which may help:

    http://www.red-gate.com/supportcenter/C ... wledgebase\ANTS_Profiler\KB200810000316.htm

    Stephen
  • Options
    Thanks for the informative link! Unfortunately, it didn't solve my problem. EXCTRLST works fine, so I know the counters exist and are accessible in some fashion. When I tried to run the "lodctr /R" command, I was told that I needed to provide a filename (e.g., "lodctr /R:[filename]") from which to restore. Should I have one of these around, or on the XP CD, perhaps?

    I tried to find more information on what "lodctr" does, and came across this link about manually rebuilding one's performance counters: http://support.microsoft.com/kb/300956

    Also, I have the export from "lodctr /S:[filename" (the opposite of "lodctr /R:[filename]"), which should show my current perf object values. Would it be helpful to see that here?

    Finally, my user account is a member of Administrators, but just to be sure, I gave it the two permissions you mentioned, to no avail. the profiler should run as me and not need a service account to be added as well, correct?
  • Options
    This should be the right command for lodctr (and .NET 2.0):

    %systemroot%\system32\lodctr /R:"%systemroot%\microsoft.net\framework\v2.0.50727\corperfmonsymbols.ini"


    Hope it helps!
  • Options
    Chris, that command executed successfully, but didn't fix my issue. At the risk of killing this topic dead, I think it's not a ANTS issue, but a Windows issue. running the EXCTRLST tool works pefectly, but its companion tool (SHOWPERF) immediately shows the error "Unable to Get Counter and Object Names from selected computer." My guess would be that whatever reason is keeping SHOWPERF from working is keeping ANTS from working as well.

    Googling the above error text hasn't yet yielded any results, but I'd be happy to hear your thoughts.

    UPDATE: When SHOWPERF does load (after clicking through the error message), I can attempt to type the computer name ("." or "//[hostname]"), and I get the error "Unable to connect to Local Machine key on selected computer". Does this ring a bell for anyone? (Google fails here, too)

    UPDATE 2: I know it's not registry permissions keeping SHOWPERF from working, as my user account is in the Administrators group. Also, to be thorough, I entered regedit and manually added Full Control of the Local Machine key to my user account.
Sign In or Register to comment.