version 14.10.1.21845 getting error connecting to SQL Azure databases

jgonneringjgonnering Posts: 34 Bronze 3
edited September 22, 2022 2:33PM in SQL Compare
since updating to the newest version I can no longer connect to SQL Azure databases.  I noticed the latest version has fix ZD-277111 that talks about populating database list when TrustServerCertificate is required which seems directly related to my new issue.  I have tried 3 authentication methods, all have the same error.
Tagged:

Best Answers

Answers

  • SujaySujay Posts: 39 Bronze 1
    edited September 26, 2022 6:04AM
    Hi Jeff,

    Thank you for your post.

    Our development team is aware of this issue and have it added to their to do list to resolve. Essentially it looks as though we are including a version (6.21) of Microsoft.IdentityModel.Abstractions.DLL with SQL Compare, however the application is expecting a old version (6.18). 
     
    While work is done to resolve this, you can either downgrade to an older version of SQL Compare (v14.9.3 - https://download.red-gate.com/checkforupdates/SQLCompare/SQLCompare_14.9.3.21711.exe) or download version 6.18 of Microsoft.IdentityModel.Abstractions.DLL and replace the newer version of it in C:\Program Files (x86)\Red Gate\SQL Compare 14.

    Please let us know if this helps.

    Best Regards,
    Sujay
    Product Support Engineer | Redgate Software

    Have you visited our 
    Help Center?
  • jgonneringjgonnering Posts: 34 Bronze 3
    edited September 26, 2022 1:56PM
    thank you.  I got a 404 error on the link you provided, but was able to get around it.  I still encountered the same errors in 14.9.3.21711.  I had to go back to 14.8.5.21499 for this issue to go away.  I will run with that version until a fix comes out.
  • jgonneringjgonnering Posts: 34 Bronze 3
    the latest version 14.10.4.22065 resolved this issue.  Thank you.
Sign In or Register to comment.