How is SQL Prompt helping your team? Share your experience.

How to turn off or delay auto-connect to highlighted database from "Red Gate Software - SQL Tools"?

EatBugsEatBugs Posts: 3 New member
Scenario: I'm trying to set multiple databases offline. Each database I highlight immediately gains one or two connections, which I then have to kill to set the db offline. It's dangerous since I could easily kill a legitimate connection unless I review existing connections in Activity for EVERY database I touch. This didn't used to be a problem!

Best Answer

  • EatBugsEatBugs Posts: 3 New member
    I figured it out! Mostly. It's not SQL Prompt that was the culprit; it was SQL Source Control. I assume because it's trying to locate source modifications, even though I didn't have it configured to any source control. Or maybe that's why it was going off script? Either way, I'll just leave that uninstalled.

Answers

  • Hi @EatBugs

    A couple of suggestions would be to use the don't load suggestions option under the connections tab, and if that doesn't work, try and untick the Show code suggestions temporarily to prevent it loading any suggestions for the server you've clicked on.




    Kind regards,

    Kurt McCormick
    Product Support Engineer, Redgate

    Need help? Take a look at our Help Center

  • EatBugsEatBugs Posts: 3 New member
    Thanks for the response! I did try both of those possibilities and it didn't stop the auto-connect 'feature' when I click on a database in SSMS. As soon as I select any database from the Object Explorer, even though I do nothing else, one or two connections show up in Processes for that database, named "Red Gate Software - SQL Tools".
  • KD1KD1 Posts: 6 Bronze 2
    Is there any updated information on this? It is also an issue for me.  The instance I am working with does not have any source control set-up ( though SSMS has it installed and I sue it for a different instance). Anytime I click  on a database in Object Explorer it leaves a connection.  I have to kill the connection to drop the database.
  • Hi @KD1,

    It'll most likely be because of having SQL Source Control installed in SSMS. When you click on a database, the SQL Source Control plugin checks to see if it's enabled for source control. You can see what I mean if you open the SQL Source Control plugin, and then click on each of your databases from the explorer window.

    Kind regards,

    Kurt McCormick
    Product Support Engineer, Redgate

    Need help? Take a look at our Help Center

Sign In or Register to comment.