Redgate SQL Source Control: ignoring Database Roles

ireminiremin Posts: 4 New member
edited July 11, 2022 7:53AM in SQL Source Control

I'm using Redgate Source Control to changetrack a database. I have a testing database from which I commit, and a production database which is the final target.

I want to have a different Database Role (the setting found of Database->Security->Roles->Database Roles) in the production database because of specific requirements. I have changed one database on my production server, but every time I deploy to the production database, the Database Role resets to the status it was before I changed it (even though the specific role is not synced).

I found a filter on Comparison Options for user roles and checked the Ignore: "User's permissions and role memberships" and deployed the filter, but the Database role still resets every time I deploy any change to production.

Is there a way to ignore Database roles or is there a workaround I could use?

Best Answer

  • Jon_KirkwoodJon_Kirkwood Brisbane, AustraliaPosts: 132 Silver 1

    Hi @iremin

     Thanks for reaching out on the Redgate forums regarding your Source Control question.

     

    Sounds like you may be able to use the Filter Rules in this instance

    From the setup tab of Source Control > Edit filter rules

     

     Items that are selected with a tick are shown on the commit tab, get latest or when you undo.

     

    If you add an 'Exclude' filter on Role you can nominate roles to skip, there are a few different logic operators to select groups of items, or you can call them out directly.

     

     

    The 'users permissions and role memberships' option doesn't exclude specific roles, just the membership of those roles.

     Hope this is of use for your requirement.

    Jon Kirkwood | Technical Support Engineer | Redgate Software

Answers

  • ireminiremin Posts: 4 New member
    This answers my question. There is a further issue with removing the role from the repository but this is a separate issue. Thank you for the information!
Sign In or Register to comment.