Be the star of a SQL Prompt case study. Learn more.

Copy as IN Clause without Unicode prefix?

TJSmithTJSmith Posts: 1 New member
Is there a setting to stop SQL Prompt from prefixing strings in the "Copy as IN Clause" list with N?

Ex: I'm trying to get 
('abc',
'def',
'ghi')

instead of 
(N'abc',
N'def',
N'ghi')

Thanks!

Best Answer

  • Kurt_MKurt_M Posts: 125 Silver 1
    Answer ✓
    Hi @TJSmith,

    I'm afraid there's no setting to control the "Copy as IN clause" in the options menu, as it works off of the type of data you're copying from. For example, if you use this copy function on a column listed as nvarchar, then it will affix the N before the value. However, if the column is a varchar, it will list the value without the N before it. 

    If changing the datatype is an option, you could adjust it from a unicode data type to something else.

    Kind regards,

    Kurt McCormick
    Product Support Engineer, Redgate

    Need help? Take a look at our Help Center

Sign In or Register to comment.