Maximize the power of SQL Prompt with SQL Toolbelt Essentials. Watch now.

SQL Prompt is throwing errors when upgraded SSMS version to 18.11.1

I recently upgraded SSMS version (v18.11.1) to be able to work with SQL Server 2019. But as soon as I reinstall SQL Prompt I started getting errors. SQL Prompt is not working. Is there any specific version of SQL Prompt needs tobe installed for this version of SSMS?
Tagged:

Answers

  • Hi there,

    Thank you for reaching out and I apologize that you are running into issues with SQL Prompt.

    As of version 10.3 of SQL Prompt, SSMS versions 18.4 and below are no longer supported because they use RegSvrEnum 15.0.18206.0 while SSMS 18.5 and later use 16.100.0.0.

    Since you are on v18.11.1, you would need to use a version of SQL Prompt above 10.3.

    Thank you!

    David Kim
    Product Support Engineer

Sign In or Register to comment.