Options

MFA broken in SqlDoc 5.2.1.2830?

zzRrrGatezzRrrGate Posts: 1 New member
MFA was working until I upgraded.  Now it seems to be broken.  On the first log in attempt I get a quick flash of a login screen.  On subsequent attempts I just get a dialog saying "Error connecting to SQL Server" "Could not connect to " and then the database server name.  I put the logging to verbose, but nothing looks informative.  I have no problem connecting using SSMS.

How do I get it working?
Tagged:

Best Answer

  • Options
    Jon_KirkwoodJon_Kirkwood Posts: 361 Silver 4
    Hi @zzRrrGate,

    Our developers have logged this as a potential bug and are currently investigating a solution.
    Our internal reference is SDOC-1974.

    As mentioned in my post above, if you are able to downgrade to v5.2.0 to continue your work and we look forward to this being resolved in a future release.
    Jon Kirkwood | Technical Support Engineer | Redgate Software

Answers

  • Options

    Hi @zzRrrGate

    Thank you for reaching out on the Redgate forums and sorry to hear about this issue with MFA in SQL Doc 5.2.1

    Has this issue jus started occurring since patching into v5.2.1? 

    Looking through our system I see a possible connection with another MFA issue recently reported and would like to see if there is a connection.


    You mentioned having verbose logging enabled, are you able to share your logs either on this forum post, or via the files.red-gate.com link below (this is a unique link and expires after 14 days)

    https://files.red-gate.com/requests/oqRYy1MK57DApfOE4qvrUk

    This will help us to verify what the core concern of this issue is and resolve it in a future release of SQL Doc


    If necessary, you may want to downgrade your install to v5.2.0 to see if it solves your MFA issue whilst the development team works on a permanent solution.

    Download link - https://download.red-gate.com/checkforupdates/SQLDoc/SQLDoc_5.2.0.2812.exe

    Jon Kirkwood | Technical Support Engineer | Redgate Software
Sign In or Register to comment.