Maximize the power of SQL Prompt with SQL Toolbelt Essentials. Watch now.

"Enable Suggestions" Not Working Correctly - SQL Promp 10.11.4.26759

Am experiencing lots of issues with my latest upgrades, enough so that it's really affecting my daily productivity.

When "Enable Suggestions" is on, sometimes when I'm writing code it inserts stuff that I really don't want and then when I disable it, then all of my intellisense is disabled and I don't get any auto-prompting for object name completion.

Any ideas on what I can/should do ?

thx
Kathy 

Answers

  • Hi @KathyG,

    I'm sorry you are experiencing this issue with SQL Prompt!

    Just for my understanding, are you finding that random suggestions are being input when you are in the process of typing your code?

    Just a thought, it may be worth increasing the delay time for when the suggestions box appears? You can do this within the Behavior section of the SQL Prompt Options (SQL Prompt > Options > Behavior) by increasing the milliseconds against 'Automatically show suggestions after'.

    I hope this helps!


    Kind regards

    Dan Jary | Redgate Software
    Have you visited our Help Center?
  • KathyGKathyG Posts: 23 Bronze 1
    Thank you Dan,

    What I would really like to do is disable code suggestions completely, without disabling intelligence or join recommendations.  It seems like unchecking Enable Suggestions would do that, but that’s not the experience I’m having.
  • Hello @KathyG,

    Thanks for your reply on this!

    Please forgive me if I am misunderstanding anything here, but Suggestions and Code Suggestions are the same thing. If you disable Code Suggestions (within the SQL Prompt Behavior options), then you will stop all suggestions.  It's also worth mentioning that when the SQL Prompt Suggestions are disabled, the native Intellisense within SSMS should continue to work (having SQL Prompt installed does not disable native Intellisense).

    It is possible to adjust what suggestions you see within the SQL Prompt Behavior options, maybe disabling suggestions for some of these individual items might be to closer to what you are looking to achieve?
    Kind regards

    Dan Jary | Redgate Software
    Have you visited our Help Center?
  • KathyGKathyG Posts: 23 Bronze 1
    The behavior I'm seeing now with the latest update is that when I'm creating code in SSMS, if Enable Suggestions is checked then I get auto completion of objects and joins, but then sometimes randomly it will put the code for a try / catch directly in my DML statement, this can happen repeatedly.

    If I uncheck Enable Suggestions then I get NO object completion, NO join suggestions.  I did open a ticket on this, because I thought a phone call might be helpful.

    I didn't follow your previous suggestion because it's not clear to me how slowing down the prompt response fixes this problem.  This seems to be related to a recent feature added to SQL Prompt to implement Phil Factor code suggestions.  Would it be possible to arrange a phone call?
  • Dan_JDan_J Posts: 279 Silver 1
    Hello @KathyG

    My apology for the delay in coming back to you on this!

    Sure, I'm happy to arrange a phone call. Please can you advise of your availability over the next couple of days/early next week? Also just to check, which time zone are you in?
    Kind regards

    Dan Jary | Redgate Software
    Have you visited our Help Center?
  • KathyGKathyG Posts: 23 Bronze 1
    On the options screen under Suggestions > Behavior.  I unchecked Use ranked suggestions and unchecked Automatically show suggestions after XX milliseconds.  That seems to have made the overall behavior much better.
  • Hi Kathy,

    Thank you for your feedback on this, I'm glad you have been able to establish a workaround here!

    Please let me know if you require any further assistance from us on this.
    Kind regards

    Dan Jary | Redgate Software
    Have you visited our Help Center?
  • KathyGKathyG Posts: 23 Bronze 1
    I did enter another ticket for this problem and am still requesting assistance.  thx v much.
Sign In or Register to comment.