sql search boxes are grayed out

kronkron Posts: 3 New member
just got a new laptop, have license for sql compare, downloaded free sql search also but cannot use as boxes are gray.  

Answers

  • I think you are running into an issue we are aware of and working on. Apologies for the hassle! As a workaround, could I ask you to try the following?

    • disconnect your SQL server from SSMS Object explorer
    • Close and reopen SQL Search
    • Reconnect your SQL Server
    Thank you!
  • kronkron Posts: 3 New member
    • My databases are not 'saved' when I exit SSMS. I add them as I need them since I work in many different ones.  
    • SQL Search also does not default to open.
    • I still tried your suggestion and still have gray boxes.  
  • Chad_MChad_M Posts: 1 New member
    I'm having the same issue.  Any other work arounds?  
  • kronkron Posts: 3 New member
    Haven't heard any other suggestions since 9/29 and it's still not working for me.  
  • pleaseplease Posts: 1 New member
    Disconnecting en reconnecting works for me. Thx.
  • BPerkinsBPerkins Posts: 1 New member
    I'm having the same problem with SSMS instances that I launch through a .CMD file. Disconnecting and reconnecting fixes the problem.

    If I launch SSMS from Windows Start with no default Server/Database then SQL Search works properly.

    Here is a snippet from by cmd file:

    CD "C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE"
    START Ssms.exe -E -S SQL01 -d warranty_us
    TIMEOUT 20 /NOBREAK

    START Ssms.exe -E -S SQL-TEST01 -d warranty_us
    TIMEOUT 20 /NOBREAK

  • mdullni1mdullni1 Posts: 26 Bronze 3
    What is the status for this fix?  It is very annoying not to mention the interruption to working to have to close all my scripts that are open SSMS, disconnect the server, open SQL Search, reconnect server.
  • 0101101001011010 Posts: 10 Bronze 2
    Seriously how much long do we what to wait for a fix, or is a reflection of cost ($0.00) of this once VERY useful tool.
  • SQLGatorSQLGator Atlanta, GAPosts: 2 New member
    I have the same issue. I am on all of the latest versions. When I go through the workarounds after reopening SQL Search, I see the two drop downs flash available while reconnecting to my server and then they go grey again as soon as the server completes its connection.  Selecting Reindex or Cancel Indexing doesn't seem to do anything either.
  • aisbergaisberg Posts: 13 Bronze 1
    often I have the same issue. Would be fine to fix it.
  • aisbergaisberg Posts: 13 Bronze 1
    and I miss the workaround mentioned here in the https://documentation.red-gate.com/ss3/troubleshooting
    workaround instructions can be found only here in the forum. 
  • SQLGatorSQLGator Atlanta, GAPosts: 2 New member
    I tried the disconnect and reconnect and the dropdowns flash for a second like they will work and then go back to grey. This hasn't worked for at least a year now.
  • jw4siujw4siu Posts: 1 New member
    I've been having the issue with the first time I bring up SQL Search in SSMS the boxes are all grayed out and I can't interact with it or type in a search. I have found that clicking on any server in the Object Explorer pane (even if not same server in context with SQL Search) fixes the issue for me each time.
  • BertGBertG Posts: 1 New member
    I had to disconnect from the server and reconnect before the search boxes became available. 
  • KWaiteKWaite Posts: 1 New member
    I'm getting this too, but only on my local DEV machine - other installations are OK.  Came to the forum and first pleased to see the issue mentioned but then disappointed that there is no real solution or comment from Redgate for an issue first mentioned over 4 months ago.  Also, the help documentation took 4 minutes to load with the https://documentation.red-gate.com/ss3 site just spinning,
  • abeerabeer Posts: 1 New member
    I am still having this issue. I've tried the workarounds, but they don't work. Will this be fixed soon?
Sign In or Register to comment.