What are the challenges you face when working across database platforms? Take the survey
Options

Why do my SQL Prompt settings keep reverting back to the default??

I'm not sure what triggers this but very often I need to into SQL Prompt options and re-apply my custom style. 
What do I need to do to have these settings stick all the time. It's very annoying and never used to do this. 

Tagged:

Answers

  • Options

    I'm sorry you're experiencing this issue with SQL Prompt! Thanks for reaching out to us on this.

    Just a few initial questions:

    What version of SQL Prompt are you seeing this issue in?

    Aside from your custom style, have you noticed any other settings that are not sticking/holding? Also, which style does it revert to?

    Finally, are you logging in as the same user each time?

    Kind regards

    Dan Jary | Redgate Software
    Have you visited our Help Center?
  • Options
    Morning Dan,

    Current version is 10.8.1.23216
    Not sure what style it reverts to, guessing Default, never really looked I just go in and change back to my custom style and not sure if any other setting revert. The main thing I notice is when commas are after the list value and not before, can't say what else might have changed.

    I've created a new custom style, then deleted both and created a new one to see if that helped. Then when it happened again I posted the issue here.

    I also normally update as soon as I get prompted that there is an update, but not the last one, thinking maybe that is why it reverts back.

    I may not use the format option a lot depends what I'm doing so it's possible it only happens when I apply an update. Can't say for certain. I could apply the latest and see if it reverts. 

    I log in as an account different from what I'm logged in on my computer. I choose Run As Different user when launching SSMS, but always the same user. 

    Thanks,
    Tom
  • Options
    Also is it possible there is a shortcut key or something that switches styles? Maybe it's something I'm doing. 
  • Options
    tvanharptvanharp Posts: 9 Bronze 1
    I've been holding off on updating to 10.8.2 as I wanted to see if that causes the style switch, but I just noticed it switched again on its own and yes it goes back the RedGate Default style. 

    Seems to switch every time i close SSMS. 

    I just reset it back to my default and confirmed it formatted a query correctly.
    I closed SSMS and opened it and now it's back to the redgate default. 

    Is there a setting file somewhere that is not being updated maybe? 

    Here's the other version info from SSMS if maybe that will help. 

    SQL Server Management Studio 15.0.18386.0
    SQL Server Management Objects (SMO) 16.100.46437.65
    Microsoft Analysis Services Client Tools 15.0.19618.0
    Microsoft Data Access Components (MDAC) 10.0.18362.1
    Microsoft MSXML 3.0 6.0 
    Microsoft .NET Framework 4.0.30319.42000
    Operating System 10.0.18363
  • Options

    Thanks for your updates on this!

    This is very interesting. I've had a think about whether it could be something to do with you running SSMS as a different user, could you please confirm where the Formatting Styles Folder key is pointing to within your registry (HKEY_CURRENT_USER\SOFTWARE\Red Gate\SQL Prompt 10)?


    Kind regards

    Dan Jary | Redgate Software
    Have you visited our Help Center?
  • Options
    tvanharptvanharp Posts: 9 Bronze 1
    So the account I normally sign in as doesn't even have a directory because I never use that account when opening SSMS I always do a run as different user.
    I logged in locally with that other account so I could see the settings. Here they are:


  • Options
    tvanharptvanharp Posts: 9 Bronze 1
    here's the file for the style I created.

  • Options
    tvanharptvanharp Posts: 9 Bronze 1
    After a restart I go into edit formatting styles and this is what I see:
    The directory matches the prev posts but the style has switched back to redgate Default.

  • Options
    tvanharptvanharp Posts: 9 Bronze 1
    Dan,
    Seems to be fixed now. 
    What I did that seemed to change this was to open SSMS under my normal account and created a custom style. Then restarted SSMS and it stuck. Then re-booted and it stuck. Then checked my alternate account and that one was stuck as well, not sure why. 
    I deleted the style from my regular account and launched SSMS as my regular account and obviously that one went back to default. I restarted SSMS under my alternate account and it stuck as well same after a reboot and same after installing the prompt update. Nothing I do seems to cause it to revert back to the redgate default. 

    So I'm calling it fixed but have no clue as to why. 
  • Options

    Thanks for your update on this and for the details!

    I'm glad to see you appear to have resolved this issue! I think keep an eye on this and don't hesitate in coming back to us on this again if this issue resurfaces.

    Kind regards

    Dan Jary | Redgate Software
    Have you visited our Help Center?
Sign In or Register to comment.