How do you use cloud databases? Take the survey.

Provider not found

Several weeks ago, SQL Monitor started showing 7 servers in [error state].  Most of these are 2008 R2 and 2014.  (Other servers with same version work fine)

RedGate error log shows many of these (per server):
ReadRegistry Internal SQL Monitor error ManagementException Provider not found

What is this doing?   Is there a command I can test with?  How to resolve?   Could this be an internal firewall issue?   or a RedGate issue?

I have updated Monitor versions several times since then with no change.

Thanks
Tagged:

Comments

  • carchercarcher Posts: 1 New member
    I am experiencing the same issue, did you find a solution for this?
  • ScottRGScottRG Posts: 10 New member
    Opened a ticket with Redgate support.  This was their response.   This did seem to work for me --  we don't have clustering.  And for me, it occurs in a few versions earlier than what they reported.

    Thank you for contacting Redgate support!
    I am sorry that you are having trouble with SQL Monitor.

    The development team is aware of this issue that occurs from SQL monitor build 11.2.13 and later. They are working on this and I will let you as soon as there is an update.

    In the meantime, the below workaround seems to stop the errors.

    1.    Find the ConfigurationFileEditor.exe tool included under the C:\Program Files\Red Gate\SQL Monitor\BaseMonitor\Tools directory of a base monitor installation.

    2.    Right-click and run the tool as an Admin

    3.    Click on the Load Configuration File option and then select the "RedGate.SqlMonitor.Engine.Alerting.Base.Service.exe.settings.config" which should be residing under the C:\ProgramData\Red Gate\SQL Monitor directory by default

    1.    It's recommended that you save a copy of the config file elsewhere before editing it further

    4.    Once you've loaded the config file, scroll to the samplers mentioned below and change the dropdown box to Disabled​​ (it should already be checked). 


    [Cluster].[SqlServer].[Properties].[Registry]
    [Cluster].[Machine].[Security]
    <span>[Cluster].[Machine].[Security].[CommunicationProtocol]<br></span>


    5. Then save the configuration file and then restart the SQL Monitor Base Monitor Windows service.

Sign In or Register to comment.