What are the challenges you face when working across database platforms? Take the survey
Options

SQL Backup - Backups have started Failing

Hi, I have had my backup job running for a long time (at least tw2elve months) but it has started failing with the error code:  SQL Backup failed with exit code: 880  SQL error code: 15404 [SQLSTATE 42000] (Error 50000).  The step failed. I have checked disk space and have plenty of space, all databases are simple recovery model. I have now upgraded also to the latest SQL Backup release and still the same. It only happens on the scheduled job and not if I run it manually and SQL version is Microsoft SQL Server 2014 (SP2-CU4)
.Any suggestions where to look next? Thanks


Tagged:

Answers

  • Options

    I'm sorry to hear you are facing this issue with SQL Backup! Thanks for reaching out to us regarding this.

    Error 880 relates to their potentially being a permissions related issue (https://documentation.red-gate.com/sbu7/errors-and-warnings/sql-backup-errors-500-5292).

    You need to ensure that the account the SQL Backup Agent service logs on as is a Windows Authenticated account with sysadmin privileges on the SQL Server. You can also see more information about permissions here: https://documentation.red-gate.com/sbu7/permissions

    If the error persists, turn off the user rights checks by creating a registry entry called SkipChecks:

    1. Open Registry Editor and locate HKEY_LOCAL_MACHINE\SOFTWARE\Red Gate\SQL Backup\BackupSettingsGlobal\(local) or <instance name>
    2. Create a new DWORD type registry entry called SkipChecks and set the data value to 1.
    3. From the Windows Services panel, stop and restart the SQL Backup Agent service.

    To reinstate user rights checks, set the data value to 0 or delete the SkipChecks entry.

    I hope this helps!






    Kind regards

    Dan Jary | Redgate Software
    Have you visited our Help Center?
Sign In or Register to comment.