What are the challenges you face when working across database platforms? Take the survey
Options

Problem with whitespace

JanezJanez Posts: 21
edited April 20, 2009 3:49PM in SQL Compare Previous Versions
Hi,

when comparing two databases I encountered the following problem (SQL Server 2005 with SP3):
1. I unhecked the option for not ignoring the whitespace (which I usually do) in project options.
2. I compared databases and there were numerious differences, but all were expected.
3. I saved synchronization script to the output file and ran the script on the second database in Management Studio to synchronize the second database with the first database (I did not use sync functionality in SQL Compare).
4. Then I refreshed project in SQL Compare and to my surprise it listed some stored procedures as different in both databases. If I click now on the particular stored procedure to see differences in the script, SQL Compare does not show any differences in the script (no differences that are usually displayed in orange color).

After some experimenting, I found out that the problem is with 'Ignore whitespace' option, although the SQL Compare does not show any differences between stored procedures regarding whitespace, it only lists them as different. If I check the option to ignore the whitespace, the stored procedures are not listed as different.

As I said before, I always used SQL Compare with the option to ignore whitespace turned off and never experienced this behaviour with previous versions of SQL Compare.

Any idea?

I can always reproduce the problem with these two databases (at least on my server), so I can send you copies of databases (without data) to try to reproduce the problem.

Comments

  • Options
    Many thanks for the backup files; I could use them to reproduce the issue perfectly.

    I have logged this as a bug with SQL Compare 8.0, hopefully it will be fixed in the next patch/release.

    For your reference the bug tracking code for the issue is SC-4462.

    Thanks again for taking the time to report this.
    Chris
Sign In or Register to comment.