Command line logging disabled, but seeing exit code 110

aaron_taaron_t Posts: 2 New member
We've got a fantastic process of downloading all database backups for DR purposes, and launching simultaneous threads of SQL Backup to restore.

The performance on a 32 vCPU server is fantastic, however, we're seeing SQL Backup exit code: 110 frequently.

We're running the latest version, so it is using SeriLog now.

In the restore command, I tried LOGTO='c:\uniquefilenameperdb.log', but it failed. I then tried adding ", NOLOG", and it's also failing... it seems that SQL Backup is still creating its own logs, then quickly deleting them. I also changed "information" to "fatal" in the SeriLog configuration, and still get there error. Again, log files show up for about a second, then they disappear. And with enough processes and restores of transaction logs, its failing pretty consistently.

Does anyone know how to truly disable logging (we're logging results through cmd files) while using the command line version? 

Thank you so much for any help you may have!


  • aaron_taaron_t Posts: 2 New member
    For anyone else who would ever have this issue... we could never get the logging to truly stop (and thereby not generate exceptions that one process couldn't access another process's log file, thereby failing the process), so we ended up using the extended stored procedure to process the restores, initiated by sqlcmd.exe.

    Worked well, and it also seemed to have improved performance.
  • Hi, could you please send me ([email protected]) the RESTORE command you were using for the command line restore?  I could not reproduce the situation where using the NOLOG option still caused SQL Backup to create a log file, then subsequently delete it.

    I would like to see which options were used, that may have changed how NOLOG works.  Thank you.
    SQL Backup - beyond compression
Sign In or Register to comment.