Maximize the power of SQL Prompt with SQL Toolbelt Essentials. Watch now.

SQL Prompt suddenly stopped working in SSMS

BarbBarb Posts: 1 New member
SQL Prompt suddenly stopped working recently.  I have reinstalled SSMS and the RedGate tools, but still get the attached error when opening SSMS.  I have the latest versions of both SSMS and Prompt.  I cannot even select anything in the SQL Prompt menu.  SQL Source control still works fine. Any suggestions?
Tagged:

Answers

  • Hi Barb,

    I'm sorry that you are experiencing some issues with the SQL Prompt tool.  This particular error might relate to a subfolder location being used for the Styles or Snippets.  When you un-install SQL Prompt, you may need to remove a couple of Registry Keys to restore the default paths prior to re-installing. 

    After un-installing SQL Prompt, to remove the relevant Windows Registry Keys, run Regedit.msc and browse to the following location:  Computer\HKEY_CURRENT_USER\SOFTWARE\Red Gate\SQL Prompt 10\

    You may see 2 entries, one for the Styles ("Formatting Styles Folder") and one for the Snippets folder ("Snippets Folder") - delete those keys if they exist.  Then re-install SQL Prompt.  This should restore the default folder locations.

    If the above fix doesn't resolve the issue - can you please send through the log files?  There is a mechanism to do this through the SQL Prompt GUI, however if this isn't loading you can look in the following folder for log files: %localappdata%\Red Gate\Logs\SQL Prompt 10

    Regards,

    David Harris.

    Product Support Engineer | Redgate Software

    Have you visited our 
    Help Center?
  • sammysungsammysung Posts: 3 New member
    I do not find any of the above steps useful. I have VM where I installed SQL Prompt, it only worked once. 
  • sammysungsammysung Posts: 3 New member
    After the first time I do not have any way to get SQL Prompt working, Non of the SQL Prompt menus do anything in the SSMS when I click any of the menus
  • Jessica RJessica R Posts: 1,319 Rose Gold 4
    Hi @sammysung,

    Sorry to hear that!

    Just to confirm, are you seeing the same "Object reference not set to an instance of an object" error?

    We've seen some issues when users have their Snippets location pointing to a folder that also contains their style files (either directly or as a sub-folder). Can I check if that's the case?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


Sign In or Register to comment.