What are the challenges you face when working across database platforms? Take the survey
Options

Error on stoplist on migration

Every time I create a new project, on tab generate migrations, I get the following:


I have sql server 2019 developer edition and I have installed full text search functionality. I have tried with many databases. The stoplist 'myStoplist' doesn't already exist I think. I opened the migration script and the reference to stopword '0' for locale ID 1030 is there only once. If I delete all the lines that create stopwords on the migration, then when I visit the generate migrations tab again, it gets processed and I get a list of something that I don't have the time to see and immediately I get a crash.
Does someone know what I do wrong, or what I need to change on my setup?
Tagged:

Answers

  • Options
    So sorry to hear you've run into this issue!

    Could you confirm the SQL Change Automation version you are using? I'll try to see if we can reproduce it locally.

    Thanks!
    Kind regards

    Tianjiao Li | Redgate Software
    Have you visited our Help Center?
  • Options
    ldalipisldalipis Posts: 2 New member
    Hello, thanks for your reply!

    The version is 4.3. The latest installed from sql toolbelt. The SQL Server installed on my PC is 2019 dev edition with full text search feature installed. I tried it out on AdventureWorks DB and on another custom DB that only had one table with 5-6 columns. I chose the local DB as source and the same DB restored on a server of my company. I believe that the server's specs are irellevant, because the problem is before the software checks for changes. The migration that it creates has a check that if 'myStoplist' doesn't exist, then create it and fill it in with a lot of stopwords. I run a select and indeed myStoplist didn't exist and also, I searched on the migration script for duplicate references of eg. stopword '0' on locale 1030, but there was only one. When I deleted the line for '0', the script was throwing the error on the screenshot but for the next stopword. When I deleted all stopwords from the script, the software was completing and tried to show me a list of changes, but only for a split second, before throwing a debug error about null reference exception.

    I hope you can reporduce!
  • Options
    Thanks for your patience!

    I was unable to reproduce. I'd like to take a look at the migration script which might help us understand what's going on.

    I'll reach out to you by email shortly.
    Kind regards

    Tianjiao Li | Redgate Software
    Have you visited our Help Center?
Sign In or Register to comment.