What are the challenges you face when working across database platforms? Take the survey
Options

Latest Update Broke SQL Prompt

Hi,

I installed the latest update to SQL Prompt but it's broken it in SSMS 17 & 18. When I open SSMS I get a SQL Prompt error dialog saying permission denied to a json file. The file doesn't exist and is very unlikely to have been removed on the day I upgraded as SSMS was working fine this morning.

There is a file in the folder with the same name but the extension sqlpromptstylev2.

I've searched for config files in the Redgate folder and can find no reference to this file. I've also searched the registry, as well as looking for the file on my C:\ but cannot find.

Could anyone please let me know how I can find where this file is referenced or why I'm now getting the error?
Tagged:

Answers

  • Options
    I've got a bit further. The path it errors on is on the network and I don't have write access. I've downgraded to v9.5 and it works but the path for the style settings is local and writable. If I upgrade to 10.6 I still get the same error. Where is the setting stored giving the full path to the settings file being used?
  • Options
    Issue resolved. It's all down to write permissions on the folder. Once that was done the JSON file was created. I still couldn't find where the setting was that pointed to that folder.
  • Options
    Hi @BobbyOwens

    So sorry for the delay! I have found we actually register the path for style file and snippets in the below registry key: 

    I hope this helps!
    Kind regards

    Tianjiao Li | Redgate Software
    Have you visited our Help Center?
Sign In or Register to comment.