Source Control Not working

I installed the source control 7 as part of the tool belt, but not able to use it. The error message is around

Could not load file or assembly 'SmartAssembly.ReportException, Version=8.0.0.0, culture=neutral, PublickKeyToken=7f......' or one of its dependencies. The system cannot find the file specified.

Please advise.
Thanks
Tagged:

Answers

  • Hi @Thakkx

    Do you recall which version where you using before?

    Does this error appear straight away when you open SSMS or when you carry out a specific action?

    Are you connecting to Azure?

    Please can you try uninstalling and reinstalling the latest version and see if that fixes the issue:

    https://download.red-gate.com/checkforupdates/SQLSourceControl/SQLSourceControl_7.2.16.11965.exe 

    Kind regards

    Victoria Wiseman | Redgate Software
    Have you visited our Help Center?
  • ThakkxThakkx Posts: 2 New member
    I did install and uninstall the software but didnt work. It looks like the issue is when i link to my TFS source control to one of the branch. It works fine when link to UAT branch but it throw this error message when link to my Dev branch. Seems something in Dev branch that it doesnt like it. I have the same issue when i try to do sql compare!!!
  • Hi @Thakkx

    I suspect there may be an object in your Dev branch that's an issue, if you don't mind I'm going to reach out via a support ticket!

    Kind regards

    Dan Calver | Redgate Software
    Have you visited our Help Center?

  • I have the same error message, but only on databases with temporal tables (system versioning). 

    If I disable System versioning on the table, I can see and commit changes, but if I enable it again the error message is back.
  • Hi @PatrickW16

    Sorry to hear you're also experiencing this issue!

    We solved the issue for the original poster, if it's the same issue please try the following solution:

    Go to the SQL Source Control config files folder: %localappdata%\Red Gate\SQL Source Control 7
    Inside the EngineOptions version tags, add:
    &lt;TeamFoundationServerDllOverride&gt;TfsExtendedClient&lt;/TeamFoundationServerDllOverride&gt;<br>

    So it should look like the following:

    1. <EngineOptions version="3" type="EngineOptions">
    2. <TeamFoundationServerDllOverride>TfsExtendedClient</TeamFoundationServerDllOverride>
    3. </EngineOptions>
    If that's not the case, let me know!

    Kind regards

    Dan Calver | Redgate Software
    Have you visited our Help Center?

  • Hi,

    Thank you for the quick response!

    Unfortunately, the fix doesn't work. Same error.
    It is a local database and I am connected to TSF, what information do you need more?

    Kind regards,
    Patrick
  • Hi @PatrickW16

    You're welcome and sorry about that, was worth a shot!

    In this case, I'm going to create a ticket under your forum email and reach out for additional information and we can troubleshoot this.

    Kind regards

    Dan Calver | Redgate Software
    Have you visited our Help Center?

Sign In or Register to comment.