What are the challenges you face when working across database platforms? Take the survey
Options

SQL Comparison SDK 8 Install fails

markaok1markaok1 Posts: 15
I've tried using the install from evaluation copy of SQL Toolbelt and the separate download link from the other post in this forum.


Here's the error from the Application Event Viewer:
Product: SQL Comparison SDK 8 -- Error 25531. Failed to open XML file \\OurServer\MyUserName\SQL Comparison SDK 8 Samples\Automating SQL Compare\C#\SQLCompareCodeSnippets.csproj, system error: -2147024891

If Version 8 isn't working is there a way I can download version 7? We're doing a Proof of Concept for automating some db work.

Thanks!
MarkA

Comments

  • Options
    Mark,

    I had no problems getting the SDK installed using the SQLToolbelt installer. Though in my case I ran the setup from a local drive, and installed to a local drive.
    It looks like perhaps you're running the installer from a network drive, or installing to a network drive? Perhaps that is causing the problem.
  • Options
    I'm running locally and installing locally. The reference to the network path is where 'My Documents' is mapped. Not sure why putting out some sample files is making the install fail...

    Thanks for your quick reply.
    MarkA
  • Options
    Well, it's possible the path to your my documents has nothing to do with it. Do you have msxml3 or higher installed on your system?
  • Options
    I've got msxml 6.0. I've got an email into Redgate on this...

    Thanks for all your suggestions...
    MarkA
  • Options
    Brian DonahueBrian Donahue Posts: 6,590 Bronze 1
    Hi,

    For sure, this is a security restriction. When opening VS projects from a network share, the intranet zone security will take effect and cause problems like this, I'd imagine. I don't think that the zone security takes into consideration that you use folder redirection in your profile.
  • Options
    Had to have a domain admin log in and install. Thanks for pointing me in the right direction.
    Thanks!
    MarkA
Sign In or Register to comment.