there are no email alert sent with version 1.2

xdaixdai Posts: 98
edited April 9, 2009 7:12AM in SQL Monitor Previous Versions
Hi

Recently we upgraded to 1.2, and noticed that some of the job failure or job did not start didn't send us email notification (they are medium alert), so it is really unreliable since we expect that we would get timely alert. Can someone help? thanks

Comments

  • kevrileykevriley Preston, UK Posts: 120 Gold 1
    I seem to have the same issue.

    I can force an email to be sent from the 'Mail Server Settings' test email button, but don't get any during the normal use of SQL Response.

    Can anyone confirm this issue?


    Kev
    Kevan Riley
    Riley Waterhouse Limited
    Twitter: @kevriley
  • Emma AEmma A Posts: 42
    edited April 8, 2009 7:40AM
    Hi Xadi,

    Sorry that you are experiencing this problem. Please could you provide answers to the following questions so that we can investigate the issue:-

    Did you fail to receive an email notification for an alert that was raised within the GUI?
    Were emails for job alerts successfully received for 1.1?
    Can you successfully send and receive a test email using 1.2?
    Is this issue present for all server instances that you are connected to?
    If you go to the Configure a server tab of the configuration dialog and navigate to the appropriate Job alerts for the server concerned
    Is the email address correctly listed in the Send email to text box?
    Are the alerts enabled?

    Thank you in advance for your information.
    Regards
    Emma
  • Hi kev,

    Sorry that you are experiencing this problem. Please could you provide answers to the following questions so that we can investigate the issue:-

    Did you fail to receive an email notification for an alert that was raised within the GUI?
    Is this issue present for all server instances that you are connected to?
    If you go to the Configure a server tab of the configuration dialog and navigate to the appropriate Job alerts for the server concerned
    Is the email address correctly listed in the Send email to text box?
    Are the alerts enabled?

    Thank you in advance for your information.
    Regards
    Emma
  • kevrileykevriley Preston, UK Posts: 120 Gold 1
    Emma, thanks for the response.

    Did you fail to receive an email notification for an alert that was raised within the GUI? Yes

    Is this issue present for all server instances that you are connected to? Yes

    If you go to the Configure a server tab of the configuration dialog and navigate to the appropriate Job alerts for the server concerned
    Is the email address correctly listed in the Send email to text box? Yes

    Are the alerts enabled? Yes
    Kevan Riley
    Riley Waterhouse Limited
    Twitter: @kevriley
  • Hi Emma, below is the answer:

    Did you fail to receive an email notification for an alert that was raised within the GUI? -- yes
    Were emails for job alerts successfully received for 1.1? -- yes
    Can you successfully send and receive a test email using 1.2? -- yes, since i am able to get some of the alert notification
    Is this issue present for all server instances that you are connected to? -- yes
    If you go to the Configure a server tab of the configuration dialog and navigate to the appropriate Job alerts for the server concerned
    Is the email address correctly listed in the Send email to text box? -- yes, since the email address is the same as some the job failure alert i received
    Are the alerts enabled? -- yes, i checked before i submit the question

    thanks
  • Thank you both for your responses.
    Please could you provide the following information:-
    Operating system with the GUI
    Operating System with the Alert repository
    Email application you are using

    Would you be able to send us your Alert Repository files so we look into this further.
    You should find them here by default on the AR machine :
    [All Users]\Application Data\Red Gate\SQL Response 1\Alert Repository

    Could you also send in the Alert repository Log file, you should find it here by default on the AR machine :
    [All Users]\Application Data\Red Gate\\Logs\SQL Response Alert Repository 1
    If you could e-mail them to support@red-gate.com referencing this forum topic, we will take a look.
    Thank you
    Emma
  • Operating system with the GUI -- windows xp pro SP2
    Operating System with the Alert repository -- windows xp pro SP2
    Email application you are using -- hoscantoemail,

    for the alert repository files, there are many of them with listed folder DB_1, DB_2...., which one you need?

    the log file dated back to when? since each day has one.

    thanks
  • Thank you for the information.
    If you could zip up the whole Alert repository folder that would be great but if not if you could provide the DB_0 folder and a few of the log files especially one for a day where you expected to receive an email notification but did not.
    Kind Regards
    Emma
  • Hi Emma,

    Currently we have db_0, db_1 to db_4, after i zip, we have 500M files, that's too big to send, any other suggesiton? thanks
  • kevrileykevriley Preston, UK Posts: 120 Gold 1
    Emma,

    strangely enough, I have come into the office this morning to see 1 alert email in my inbox. There have been over 50 alerts triggered overnight, but only 1 email.

    In the AlertRepositoryLogFile.Log
    there is a line

    00:59:46.306|Info |AlertRepository |4 |Mail sent OK

    Don't know if this helps or hinders the issue?


    Kev
    Kevan Riley
    Riley Waterhouse Limited
    Twitter: @kevriley
  • Hi Xadi,
    Thank you for the data, please could you let me know, what version of SQL you are connecting to and what operating systems are they running on?
    Cheers
    Emma
  • Hi Kev
    Thank you for the information about the email alerts and log file.

    We have managed to encounter an email alert not triggering similar to what you are experiencing.

    Please could you provide the following information:-
    Operating system with the GUI
    Operating System with the Alert repository
    Email application you are using
    What version of sql server are you trying to connect too and what operating sytem are they running on.


    Would you be able to send us your Alert Repository log files so we can look into this further.
    You should find them here by default on the AR machine :
    [All Users]\Application Data\Red Gate\SQL Response 1\Alert Repository

    Could you also send in the Alert repository Log file, you should find it here by default on the AR machine :
    [All Users]\Application Data\Red Gate\\Logs\SQL Response Alert Repository 1
    If you could e-mail them to support@red-gate.com referencing this forum topic, we will take a look.
    Thank you
    Emma
  • Hi Xadi and Kev,

    Are you receiving an email notification the first time an alert is raised but
    not for subsequent occurences of that alert?

    Have you cleared the alert and then still not received an email when it re-occurs?

    Kind Regards
    Emma
  • kevrileykevriley Preston, UK Posts: 120 Gold 1
    Emma,

    yes that's it!!

    I cleared all outstanding alerts, and now my inbox is filling nicely!

    I am getting it for new, first time alerts but not for subsequent. I believe that this is by design.

    If I clear the alert, I do get the email the next time.

    That will teach me to clear the alerts down properly, and not just let them expire from the current view.


    Thanks,
    Kev
    Kevan Riley
    Riley Waterhouse Limited
    Twitter: @kevriley
  • Hi Kev,

    That is great news and yes it was by design so that people did not get spammed with emails.
    The ability to configure the frequency of emails is under consideration for a future release. If you have any other problems please do not hesitate to contact us and apologies for the delay in responding to you.

    Best Wishes
    Emma
Sign In or Register to comment.