Sql Source Control v7.1 fails Commit action on SSMS 18.8

Sql Src Control     v7.1.29.11028
SSMS                  18.8  v15.0.18369.0
VS 2019 Pro         v16.8.4
Sql Server            v15.0.4073.23   HADR Enabled
Azure DevOps Server 2019      Version Dev17.M153.5

When I attempt to Commit I get this error: policy assembly Microsoft.TeamFoundation.VersionControl.Controls is not registered
This commit doesn't meet the server's policy requirements, or the policy isn't configured on your machine. The server returned the following:
Internal error in Work Items. Error loading the Work Items policy (The policy assembly 'Microsoft.TeamFoundation.VersionControl.Controls, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' is not registered.). Installation instructions: 

I have tried the update to set the RedGate_SQLSourceControl_Engine_EngineOptions.xml file by inserting this:
I still get the same error.
And yes, #IgnorePolicies works, but then my User Stories will not get updated, right?

So what do I do?


Sign In or Register to comment.