Mark as Deployed - Cannot write to database

Using VS Professional 2019 Version 16.7.6, Redgate SQL Change Automation   4.3.21012.23821...
When i press the "Mark as Deployed" button, on a freshly, successfully executed script, I occasionally get a "script syntax error" dialog box that says
"Cannot write to database ... as an operation is already in progress.  Do you still want to mark the script as deployed?  YES/NO"
I can execute the script successfully, with no warnings or errors.   ("No issues found" appears at the bottom of the T-SQL panel.)    
Usually, if I wait a few moments, pressing "Mark as Deployed" works fine.   Today, I have a situation where I cannot get past this dialog if I press NO and try again.
Should I stop being stubborn and just press YES?
Thanks.

Best Answer

  • FarmboyEsqFarmboyEsq Posts: 4 New member
    Accepted Answer
    Well, my next script worked flawlessly, so, I copied the content of the failing script to a new script, and it worked too.    Deleted the old.   Renamed the new, working version.   I'm good to go now.
Sign In or Register to comment.