New training course: Customizing SQL Prompt. Watch now.

SQL Prompt - L O N G delay in showing suggestions

In the past week, for whatever reason, SQL Prompt now has a very long, delayed response when offering suggestions. It's so bad that I have been using type-ahead and ignoring the prompts, but at this point, I feel that the only way to be productive is to actually disable SQL prompt. Obviously this is not what I want to do.

I was prompted about a slow "cache" rate and followed the suggestions there but it has not made any difference.

I use this tool constantly throughout the day and right now my productivity has been diminished in Transact-SQL. There must be some type of fix or work-through for this. Any help is greatly appreciated.

Answers

  • Hi @HampdenTech81

    So sorry to hear you've run into a performance issue!

    If not already, it may be worth trying to clear the SQL Prompt memory by disabling suggestions and then re-enabling it. 

    How many databases do you usually connect in SSMS? SQL Prompt loads suggestions for all databases specified in a query. However, to improve the performance of SQL Prompt you might want to include/exclude certain servers, databases or schemas. https://documentation.red-gate.com/sp/managing-sql-prompt-behavior/managing-connections-and-memory 

    If the problem persists, it'll be useful to check your SQL Prompt logs. I'll reach out to you by email shortly!


    Kind regards

    Tianjiao Li | Redgate Software
    Have you visited our Help Center?
  • Thanks for the reply. I meant to respond yesterday but never got the change. I disabled suggestions and worked that way for a while and quickly realized how much I depend on SQL Prompt  :D so I enabled them again. When I did, the buffering seemed to go away.

    I work with about 15 DB's, but I have excluded those DB's that I seldom work with. 
Sign In or Register to comment.