What are the challenges you face when working across database platforms? Take the survey
Options

SQL Prompt Unusable After Update

I updated to the new version of SQL Prompt when notified. Usually I wait until first thing in the morning but SQL Search wasn't working and I thought that might resolve the problem. When SQL Studio restarted I received Enum value 'Never' is not supported" and none of the SQL Prompt functionality was working. I could see the menu item and sub items but nothing happened when I clicked on anything. SQL Search was now working. I tried uninstalling SQL Prompt and reinstalling the latest version, same error. I uninstalled SQL Prompt and installed the previous version and received "Encountered unknown SSMS version 15.100.0.0". I'm running 15.0.18358 of SQL Studio and it says that is the latest version. I also tried uninstalling all Red Gate products and reinstalling - same Enum error. Does anyone have suggestions?

Best Answer

  • Options
    ostandageostandage Posts: 75 Silver 1
    Hi @Jaclyn

    Apologies for the inconvenience caused.

    We are aware of an issue affecting a small number of users on upgrade to SQL Prompt 10.5, we have a fix for this issue and aim to release it today in 10.5.1.

    If you are blocked from using SSMS and need to use it before we release 10.5.1, please try moving your styles directory on disk to another location. This will mean any custom styles won't show in SQL Prompt. You will be able to move this back after upgrading to 10.5.1.

    Thanks, 

    Owen
    Software Engineer
    SQL Prompt / SQL Search

Answers

  • Options
    JaclynJaclyn Posts: 4 Bronze 1
    I was able to resume using SQLPrompt after moving the Styles and the StylesV2 folders.
  • Options
    ostandage I have same case, today I did update ssms to 18.7.1 and sql prompt to current version, so I had nitify error window on start ssms. Sql promt is not works. I removed both folder with styles, no one changes.
    Any suggestions?

  • Options
    CaroLopezCaroLopez Posts: 3 New member
    @ostandage, same issue than @Frankie4Fingers. Issue when I start SSMS and then SQL prompt is not available.
    But I do not have access to any style folder.
    On my AppData\Local\Red Gate folder I only have SQL Test and Source Control.
    SQL Prompt is only available on the log folder with the last log message:

    2020-12-16 10:38:54.350 +01:00|Information||| Launching package entry point Ssms18 (version 15.0.18358.0) for SQL Prompt 10.5.0.16982.
    2020-12-16 10:38:54.566 +01:00|Information||| BaseConnect(RedGate.SQLPrompt.SsmsPackage18.ConnectAdapter) constructed successfully
    2020-12-16 10:38:54.655 +01:00|Information||| Initialising DTE and AddIn connections.
    ***
    DTE.FullName = C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\Ssms.exe, DTE.Version = 2019.0150,
    DTE.CommandLine = ,
    ***
    AddIn.Name = SQL Prompt, AddIn.ProgID = RedGate.SQLPrompt.Package,
    AddIn.Description = SQL Prompt
    2020-12-16 10:38:54.660 +01:00|Information||| Current culture en-US
    2020-12-16 10:38:54.660 +01:00|Information||| AddIn.SatelliteDllPath = null
    2020-12-16 10:38:55.351 +01:00|Error||| Report error dialog UI shown
    2020-12-16 10:39:00.487 +01:00|Information||| Exception report ('Impossible de créer un fichier déjà existant.
    ') processed.

    Impossible de créer un fichier déjà existant. -> Impossible to create a file already existing

    Thanks
  • Options
    @Jaclyn @Frankie4Fingers @CaroLopez

    We have released a new version with a bug fix for this issue, you can upgrade here:
    https://download.red-gate.com/checkforupdates/SQLPrompt/SQLPrompt_10.5.2.17186.exe 
    Kind regards

    Victoria Wiseman | Redgate Software
    Have you visited our Help Center?
  • Options
    CaroLopezCaroLopez Posts: 3 New member
    Hello,
    @Victoria W thanks but still not working for me. I had a webex meeting yesterday with one of your colleague and I've reinstall the 10.4 version. Now it is working. We will wait for january for an updates on 10.5 issues we have.

    Thanks for your help,
    Caroline
  • Options
    JaclynJaclyn Posts: 4 Bronze 1
    @Victoria W - I installed from your provided link and was able to work; however, I had to recreate all of my styles.
  • Options
    EmbeeEmbee Posts: 1 New member
    In my case, I found that I had 2 snippets with the same name
Sign In or Register to comment.