Problem configuring Azure Devops YAML pipeline

NiekNiek Posts: 2 New member
edited November 18, 2020 10:51AM in SmartAssembly
Hello all,

I am configuring my yaml build pipeline. The goal is to obfuscate an exe during the build. I found this guide:https://documentation.red-gate.com/sa7/building-your-assembly/using-smartassembly-with-azure-pipelines

Smartassembly seems to be installed correctly, as I verified my published artifacts. However the build logs indicate that the executables are obfuscated by a "Evaluation" version of Smartassembly.

It seems like the RG_LICENSE property is being ignored? 

This is a snipped of the powershell command that I execute:
$p = Start-Process -FilePath msiexec -Args "/qn /i `"$msiPath`" INSTALLDIR=`"$saInstallLocation`" RG_LICENSE=`"$(SA_KEY)`" RG_WARNING=`"Ignore`" REBOOT=`"ReallySuppress`" RG_I=`"Red Gate Software Ltd.`"" -Wait -Verbose -PassThru

I already tried to run the command without the SA_KEY variable (setting the license hardcoded).

Can anyone help me with this issue?

Best Answer

Sign In or Register to comment.