Maximize the power of SQL Prompt with SQL Toolbelt Essentials. Watch now.

SQL Prompt 10.4.2 in SSMS 18.6 error with "Find Invalid Object", "Smart Rename" and "Split Table"

Find Invalid Object: fizzes the screen and then after fews seconds SSMS closes

Smart Rename and Split Table: blocking error -> The file or assembly 'Microsoft.Data.SqlClient, Version = 2.0.20168.4, Culture = neutral, PublicKeyToken = 23ec7fc2d6eaa4a5' or one of its dependencies could not be loaded. Cannot find the specified file.

Tagged:

Best Answer

  • ostandageostandage CambridgePosts: 67 Silver 1
    Hi @matpez

    Thank you for your feedback and screenshots. We are currently working on this fixing these issues (unfortunately not ready for releasing this week).

    We can't guarantee a time frame, but we aim to fix this early next week.

    Thanks, 

    Owen
    Software Engineer
    SQL Prompt / SQL Search

Answers

  • Andrea_AngellaAndrea_Angella Cambridge, UK Posts: 67 Silver 4
    Thank you for reporting the issue and sorry for the inconvenience. We'll fix this asap. Thanks
    Andrea Angella
    Lead Software Engineer | Red Gate
    Website: www.productivecsharp.com
    Twitter: @angella_andrea
  • matpezmatpez Posts: 6 New member
    Hi, do you have any timing for fix it?
  • matpezmatpez Posts: 6 New member
    edited October 9, 2020 1:59PM
    Hi, I just updated to "SQL Prompt 10.4.3"

    I make these considerations:
    • Smart Rename: no longer has the assembly not found error. However, it has another problem: when you press the "view" key which should open a new screen with the query, the "new query" is tried to open with the connection in "Windows Authentication" mode. Since I use the "SQL Authentication" mode it is very inconvenient and previously worked correctly!

    • Split Table: here too the assembly error is gone. Too bad there is the same connection problem written above. The screen on opening reports an error saying that it cannot connect with my windows user. Being a blocking error, I can only close the screen.

    • Find Invalid Object: unfortunately it still remains unusable. The screen does not locate the database and does not even have an entry in the drop-down list. So it can't be used.
    -----------------------------------------------------------------------------------------------------------------------

    I am attaching images



    -----------------------------------------------------------------------------------------------------------------------


  • Tianjiao_LiTianjiao_Li Posts: 684 Rose Gold 5
    edited October 9, 2020 4:25PM
    Thanks @matpez

    The development team is working on those issues and I'll make sure to update here once the fixes are done.

    Our apologies for the inconvenience it's causing.
    Kind regards

    Tianjiao Li | Redgate Software
    Have you visited our Help Center?
  • AdrianBAdrianB Cambridge, UK Posts: 46 Silver 1
    This issue has now been fixed. The fix is available in SQL Prompt v10.4.4.
    Software Engineer
    Redgate Software
  • matpezmatpez Posts: 6 New member
    Thanks a lot... all fixed!!  :)
Sign In or Register to comment.