Bug - Excluded columns using the keyboard not saved

Hi, I hit a strange problem: when I exclude some columns using the keyboard with the spacebar, these columns are not saved to the project so the next time I open the project, I must de-select them again. I have been able to reproduce this many times under a variety of scenarios, for exemple by mixing them with some columns selected with the mouse: those selected with the mouse are saved but not those with the keyboard; so it's not simply because I forgot to save the project.

Also, as a new feature request, I would like to have the possibility of deselecting all the columns - excerpt the primary key - in a single step or, at least, to have the possibility of selecting a block of them instead of having to click on each one by one.

Having the possibility of a global function for de-selecting them all for all tables excerpt for the primary and the foreign keys would be great, too.

The reason for this is that sometime, I have a database with sensitive data and I would like to copy only the strictest minimum of things for debugging purpose and some of these tables have many hundred of columns; so it's very long to have to deselected them all (especially when you have to do it again - many times - because they have not been saved in the project).

BTW, another feature request would be the ability to add a title to each project; possibly along with a commentary.

Version: SQL Data Compare running on WinXP Pro.

Sylvain Lafontaine, ing.


  • Options
    Bug reproduced by the Red-Gate's support team and logged with the reference SDC-907. It will be looked at in the next release of SQL Data Compare although there is no timescales for this at present.

    As for the request for the new features, they have been logged with the reference SDC-908 and will be considered for a future release of SQL data Compare.

    This thread is now closed.

    Thanks everyone.
    S. L.
Sign In or Register to comment.