What are the challenges you face when working across database platforms? Take the survey
Options

How do I set Redgate change automation build to not use transactions - AWS deploy issue

I have a pipeline in azure devops which uses Redgate change automation and receives the following error with linked server when release runs -

2020-08-20T21:29:01.4937371Z The database update failed
2020-08-20T21:29:01.5136114Z ##[error]System.Management.Automation.CmdletInvocationException: Applying update script failed: The operation could not be performed because OLE DB provider "SQLNCLI11" for linked server "XXXXX" was unable to begin a distributed transaction.
2020-08-20T21:29:01.5137583Z OLE DB provider "SQLNCLI11" for linked server "XXXXX" returned message "The partner transaction manager has disabled its support for remote/network transactions.".
2020-08-20T21:29:01.5138937Z Local parameters [connectionString = Data Source=XXXXX;Initial Catalog=XXXXX;Integrated Security=True;Pooling=False;Trust Server Certificate=True;Application Name="SQL Change Automation"] ---> RedGate.Versioning.Automation.Shared.Errors.TerminatingException: Applying update script failed: The operation could not be performed because OLE DB provider "SQLNCLI11" for linked server "XXXXX" was unable to begin a distributed transaction.
2020-08-20T21:29:01.5140660Z OLE DB provider "SQLNCLI11" for linked server "XXXXX" returned message "The partner transaction manager has disabled its support for remote/network transactions.". ---> Microsoft.Data.SqlClient.SqlException: The operation could not be performed because OLE DB provider "SQLNCLI11" for linked server "XXXXX" was unable to begin a distributed transaction.
2020-08-20T21:29:01.5142040Z OLE DB provider "SQLNCLI11" for linked server "XXXXXX" returned message "The partner transaction manager has disabled its support for remote/network transactions.".

I have tried changing the transaction isolation level to Read Uncommitted in the build but same error.

How do I set it to no transactions from the gui?

Tagged:

Answers

Sign In or Register to comment.