New features added to SQL Prompt Watch now.

Error when loading SSMS: Root element is missing

MonicaYMonicaY Posts: 5 New member
I had an issue with low storage on my cpu and I had ssms running at the time. SSMS crashed and now everytime I load it, I get a SQL Prompt error. The only error details are "Root element is missing". SQL Prompt is no longer working at all.
I tried uninstalling SSMS and all Redgate products, then reinstalling them, but the error still persists.

How can I fix this issue?

Answers

  • MonicaYMonicaY Posts: 5 New member
    I fixed this. I had to uninstall SQL Prompt again. Then I did a search in my C drive for "SQL Prompt" and deleted the folders in the App Roaming and Local directories. Then I reinstalled SQL Prompt again. This got rid of the error and it's working properly again.
  • rwprwp Posts: 2 New member
    I had my drive run out of space and SSMS started to throw errors. Now I get the same error identified above by MonicaY. "Root element is missing". I tried to replicate MonicaY's actions, but do not find those directories. I have removed and reinstalled both SSMS and Redgate Tools. No luck.

    Any suggestions?
  • ostandageostandage Cambridge Posts: 66 Silver 1
    Hi @rwp

    It sounds as though one of your SQL Prompt options files has become corrupt. These can be reset by deleting the SQL Prompt 10 folder here: 
    %localappdata%\Red Gate\SQL Prompt 10\

    Please note this will delete all of your SQL Prompt settings, and any custom formatting styles and snippets. If you require these please copy the folder to another location before deleting the folder from App Data and we can attempt to recover them.

    Thanks, 

    Owen

    Software Engineer
    SQL Prompt / SQL Search
  • MonicaYMonicaY Posts: 5 New member
    Thank you Owen. I will try that if it happens again. 
  • rwprwp Posts: 2 New member
    Owen,

    Thanks for the quick response. I tried your suggestion of removing the %localappdata%\Red Gate\SQL Prompt 10\ folder and then ran a repair on SQL Prompt 10 through Control Panel. That did not resolve the issue.

    So I went back to MonicaY's suggestion and got some help finding the directories she referenced. On my machine they are:
      C:\Users\%User%\AppData\Local\Red Gate\SQL Prompt 10\
      C:\Users\%User%\AppData\Roaming\Red Gate\SQL Prompt 10\

    I removed both these directories and again ran a repair on SQL Prompt 10 through Control Panel. This did resolved the issue. I have lost my Tab History, color coding and format styles, but I am not sure at what point that happened. Anyway, I am happy to have SQL Prompt working again.

    Thanks for the help.
  • cbristolcbristol Posts: 1 New member
    I had this happen to me today after SSMS crashed. I tried uninstalling/reinstalling which did not help.

    I stumbled into this, which suggested that I delete the %LOCALAPPDATA%\Red Gate\SQL Prompt 10\ and %APPDATA%\Red Gate\SQL Prompt 10\ directories, but as I started to do that, I noticed there was some .xml files in the %LOCALAPPDATA%\Red Gate\SQL Prompt 10\ folder. One of those files was 0KB in size, so I suspected it was the culprit. In my case, it was RedGate_SQLPrompt_CommonUI_Options_UIOptions.xml which I renamed to RedGate_SQLPrompt_CommonUI_Options_UIOptions.xml.old.

    I restarted SSMS and SQL Prompt came back to life. I would recommend renaming/deleting any 0KB .xml files in this directory before uninstalling or deleting the whole folder permanently as this will keep your settings, tab history, and a bunch of other stuff you would lose (or at least have to backup and restore) if you delete the folder entirely.
Sign In or Register to comment.