Ignore SSL in Slack Integration

ChitoChito Posts: 2 New member
I am getting this message "The request was aborted: Could not create SSL/TLS secure channel.": in my SQL monitor Slack integration.  Is there a configuration to get around this?  ReportGenerator have this option by adding a row in the settings.KeyValuePairs table in the monitor database

{code}
INSERT INTO [settings].[KeyValuePairs]
           ([KeyName]
           ,[KeyValue]
           ,[KeyValueType])
     VALUES ('Reporting-IgnoreSSLErrors','True','BOOLEAN')
{code}

Tagged:

Answers

  • Russell DRussell D Posts: 1,295 Diamond 5
    There isn't I'm afraid - I guess the question is what is throwing that error - are you sending to a https webhook?
    Have you visited our Help Centre?
  • ChitoChito Posts: 2 New member
    Yes it is webhook.  It's the Slack integration in the Notification settings. 


  • Depending on the version you're using there is a separate generic "webhook" notification option:


    And the general webhoook notifications does have an option to "Ignore SSL or TLS certificate errors".  However it does not have the Slack specific functionality.

    It seems the problem may be that Slack only supports TLS 1.2 and you are trying to access it from a machine that does not have that enabled (or is an older one where it is not the default or cannot have it enabled).
    Product Support Engineer | Redgate Software

    Have you visited our Help Center?
Sign In or Register to comment.